Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-09-2017, 01:37 PM   #1
Winnebago Camper
 
Join Date: Dec 2017
Posts: 7
Generator 25amp breaker trips on startup

We bought a 2018 Minnie Winnie 22M on August 29, 2017. The dealer installed an GoPower Elite system for us. IC2000 inverter/charger with internal transfer switch. On our initial trip to check it out everything seemed to work when plugged into shore power. We then then moved to a dry site. We plugged the shore power cord into the generator receptacle per the manual. The generator fired up no problem but the coach had no power.

Took it into Fraserway believing it to be a warranty issue. They had it for about a month. When we picked it up, they said the 25amp breaker on the Onan tripped every time the generator was started. The solution they offered was to start the generator without the plug in. Wait 30 seconds to 2 minuets (depending on the tech) then plug it in. Or install a transfer switch at a cost of approximately $700.

Another suggestion they & the Winnebago help line said would be to try shutting off the main panel 30amp breaker with the generator plugged in to see if the generator 25amp would trip after waiting the specified time and switching the main breaker back on.

I also talked to Cummins/Onan. They sent me a operators manual. It suggested it would take a short or an overload to trip the 25amp breaker. Fraserway said their test indicated no short or overload.

I also read in the inverter manual that it was possible to set max power draw to the generator’s 25amps (the default on the inverter is 30amps)

Suggestions?
Pnutbutter is offline   Reply With Quote
Old 12-17-2017, 10:27 PM   #2
Site Team
 
macnut's Avatar
 
Join Date: Jun 2012
Location: CA
Posts: 706
Still sounds like a warranty issue to me. Hopefully others with more electrical knowledge will have an idea.
macnut is offline   Reply With Quote
Old 12-18-2017, 09:46 AM   #3
Winnebago Camper
 
Join Date: Apr 2013
Posts: 21
Sounds like the circuit breaker is tripping on the inrush as there is no delay when you are plugged in directly. Do you know if the air conditioner was on?

I thought all Minnie Winnie motorhomes had a 4KY Cummins Onan generator? If so, it should have a 30 amp circuit breaker on the generator.
lotsoftoys is offline   Reply With Quote
Old 12-19-2017, 05:48 AM   #4
Winnie-Wise
 
Join Date: Mar 2015
Posts: 391
Check your manual. Maybe you need a bigger circuit breaker. Surprised a transfer switch wasn't part of the install. I think a transfer switch is a $200-$300 item + labor if you can't do it yourself.
__________________
Sue and Tom

2015 Winnebago Vista 36Y
Sue46 is offline   Reply With Quote
Old 12-19-2017, 02:11 PM   #5
Winnebago Camper
 
Join Date: Dec 2017
Posts: 7
Quote:
Originally Posted by lotsoftoys View Post
Sounds like the circuit breaker is tripping on the inrush as there is no delay when you are plugged in directly. Do you know if the air conditioner was on?

I thought all Minnie Winnie motorhomes had a 4KY Cummins Onan generator? If so, it should have a 30 amp circuit breaker on the generator.
Nothing on except the inverter/charger in sense mode I believe.
Pnutbutter is offline   Reply With Quote
Old 12-19-2017, 02:12 PM   #6
Winnebago Camper
 
Join Date: Dec 2017
Posts: 7
Nothing on except the inverter/charger in sense mode I believe.
Pnutbutter is offline   Reply With Quote
Reply

Tags
generator


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 Journey second a/c compressor trips breaker Kelm130 Winnebago Class A Motorhomes 10 08-22-2014 06:07 AM
New Season startup Blues... Refig no work. pameridan04 Heating, Cooling and Appliances 12 04-23-2012 06:41 PM
Two trips, three problems BigRedLancer Winnebago General Discussions 6 10-09-2006 06:06 PM
Genset "bangs" at startup and shutdown? RanchoVectra Electrical | Charging, Solar and Electronics 24 08-05-2006 06:22 AM
Power Surge With Gen Startup LazyDog Electrical | Charging, Solar and Electronics 13 03-08-2006 03:18 AM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:02 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×