Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-17-2021, 04:14 PM   #1
Winnebago Watcher
 
Join Date: Feb 2021
Posts: 2
1987 Winnebago LaSharo Temperature indicator

Hi everyone , my name is Mel and I have a 1987 Winnebago LaSharo I have been restoring . It is running and I have 2 issues I'm having . One is the brakes. Even though it has a brake booster I still have to put a lot of pressure on the peddle, and they will not lock up so it 's taking more distance to stop . The second issue is a indicator lamp for temperature. It keeps blinking after a couple of minutes of running the motor. The instrument cluster has a temperature gauge which reads cold then to normal after the motor gets to normal operating . I have no idea of what this indicator lamp is for . Any help with this is greatly appreciated .
Melvin B is offline   Reply With Quote
Old 02-17-2021, 10:17 PM   #2
Winnebago Master
 
Eagle5's Avatar
 
Join Date: Mar 2019
Location: South Bend, WA
Posts: 678
Hi Melvin,
As your 1987 LaSharo is now 34 years old, I believe you should consider all new brake components. Based on the Renault Trafic, your LaSharo might need new rotors, rebuilt calipers & new pads. I never try to recondition brake parts myself; I just replace them.
Perhaps the blinking indicator light is from a bad electric cooling fan? Since this is a 1987, you should be able to get some codes from the computer which should help. Many auto part stores will read the codes for you for free.
Welcome to the Forum.
Eagle5
__________________
2019 Minnie Winnie 22M on an E-450 frame
Eagle5 is offline   Reply With Quote
Old 02-22-2021, 03:28 PM   #3
Winnebago Watcher
 
Join Date: Feb 2021
Posts: 2
1987 Lasharo

Thanks Eagle 5 Here's what I've already done so far on the brakes. New master cylinder , new brake fluid through out , both calipers(dual pistons) and rear cylinders blead till clean fluid flows, new brake pads on front , rear pads are fine. Rotors and drums in great shape, only has 60k miles on it. No apparent vacuum leak to or at brake booster. I am leaning towards eather a bad brake limiter on the rear brakes or the front calipers are not sliding . Only other possibility I can think of is a bad booster, but according to the manual I have when I pump the brakes in park the motor does change idle speed indicating it is working.
As far as a bad fan causing a indicator light , both fans are working and coming on when motor reaches temp and going off when it cools down. Does anyone know if this system has a dual temp indicators ? If so where would the sensor that operates the indicator lamp be , not the one for the gauge ?
Melvin B is offline   Reply With Quote
Old 02-22-2021, 03:51 PM   #4
Winnebago Master
 
Eagle5's Avatar
 
Join Date: Mar 2019
Location: South Bend, WA
Posts: 678
Hi Melvin,
I would next replace the front calipers with rebuilt calipers. Sounds like you have eliminated all other expected possibilities.
Any chance to get a code reading on the computer?
Thanks, Eagle5
__________________
2019 Minnie Winnie 22M on an E-450 frame
Eagle5 is offline   Reply With Quote
Old 02-22-2021, 06:01 PM   #5
Winnebago Camper
 
Join Date: Feb 2021
Posts: 9
Hello, I'm brand new to the forum. I cannot figure out how to post my first post on the Welcome Mat board. Maybe you could help me out?
MinnieSews is offline   Reply With Quote
Old 02-22-2021, 06:08 PM   #6
Winnebago Master
 
Eagle5's Avatar
 
Join Date: Mar 2019
Location: South Bend, WA
Posts: 678
Hi MinnieSews,
When you first click into <Welcome Mat>, you will see a list of Threads. Both above and below this list, on the left-hand side, you will see <New Thread>. Click that, and you are off to the races!
Welcome to the Forum.
Eagle5
__________________
2019 Minnie Winnie 22M on an E-450 frame
Eagle5 is offline   Reply With Quote
Reply

Tags
cat, winnebago


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hello, I am a new user 1988 LaSharo JackieRM Welcome Mat 1 05-23-2020 08:48 PM
New Owners of 1986 Lasharo nanaf Welcome Mat 1 07-26-2019 08:28 AM
black water tank indicator lights richierich Plumbing | Systems and Fixtures 20 09-21-2007 06:09 AM
Tank level indicator panel, basement AFChap Plumbing | Systems and Fixtures 8 03-13-2006 04:57 AM
Journey Dash Indicator Light Problem Demoman Winnebago Class A Motorhomes 9 08-01-2005 09:56 AM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 03:17 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
×