Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-29-2021, 06:18 PM   #1
Winnebago Watcher
 
Join Date: Aug 2021
Posts: 3
1987 GMC Wiring (lights)

There's a mystery relay just past the light switch harness. It has Green, Tan and Yellow wires feeding into it. I'm not sure what activates it, or what it's purpose is.

I had problems w the lights after I replaced the switch and fixed a load of bad connections poorly made at the factory, although I could see how they might be up to standard for domestic manufacturing during the 80's. Just cheap crimp connects, weird transitions to skinny then back to heavier gauge wire.

See photos. I will try to post them after this, as I already wrote this post once and it was not saved by the board when i attempted to upload photos.
JohnM is offline   Reply With Quote
Old 08-29-2021, 06:21 PM   #2
Winnebago Watcher
 
Join Date: Aug 2021
Posts: 3
hooray, image upload seems to work

So that's the back of the relay socket after i took it down. And that harness connector lying on the floor i have repaired, although from testing and knowing that the yellow (+12v power) wire and tan wire have to be jumpered, it tells me that

Yellow on NO
and Tan on NC

are never going to connect. These wires were some of the overheated ones I had to repair. I may (or must) have socketed them wrong when reassembling the harness.
Attached Thumbnails
Click image for larger version

Name:	20210829_183838.jpg
Views:	5
Size:	148.2 KB
ID:	180698   Click image for larger version

Name:	20210829_183805.jpg
Views:	5
Size:	189.6 KB
ID:	180699  

JohnM is offline   Reply With Quote
Old 08-29-2021, 06:24 PM   #3
Winnebago Watcher
 
Join Date: Aug 2021
Posts: 3
if you look up under the dash, just to the left of the steering column, this is where the relay goes. Between the grey box and the black box.

And no I don't know what either do but suspect one has to do with cruise control.

My cruise doesn't work anymore either, neither do the lights on top in front and back. So that's a missing connection I didn't re-establish after fixing a myriad of bad [what I assume were factory] connections.
Attached Thumbnails
Click image for larger version

Name:	20210829_183853.jpg
Views:	7
Size:	136.9 KB
ID:	180701  
JohnM is offline   Reply With Quote
Reply

Tags
light, lights, wiring


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
new member - 1987 Winnebago Le Sharo hjehje Welcome Mat 3 06-03-2021 11:48 PM
1987 Winnebago LaSharo Temperature indicator Melvin B Welcome Mat 5 02-22-2021 06:08 PM
GMC Terrain Roamn4 Towing, Hitching and Vehicles 3 11-06-2017 10:35 PM
Towing GMC Canyon Dardale Towing, Hitching and Vehicles 11 10-28-2017 09:26 AM
Flat towing 4wd gmc Dardale Towing, Hitching and Vehicles 3 09-27-2017 06:32 PM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 08:07 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
×