Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-28-2019, 04:49 AM   #1
Winnebago Watcher
 
Join Date: Mar 2019
Location: On the Move!
Posts: 1
Turn Signal/Brake Light/Running Light

I feel like I should have figured this out by now, but I haven't, so here I come!

We have a 2013 Vista 35B. All electrical systems had been working fine. Bought a Blue Ox tow bar and had the installer build a wiring harness for us to connect to our toad. The harness lasted about 3 months and then fell apart in grand fashion. Sparks and smoke and stuff you would hope not to see .

We have since replaced the harness and all is good with the toad (all lights work), but the Vista left side running lights, left blinker, and left brake light stopped working. Everything else seems fine. Checked all fuses and bulbs are fine. Don't know enough to trouble shoot beyond this. Thoughts?

Thanks!
jriley is offline   Reply With Quote
Old 03-28-2019, 06:47 AM   #2
Itasca Owners
 
Teamfoxy's Avatar
 
Join Date: May 2018
Location: Sebastian Florida
Posts: 127
Generally WBO has a premade harness for lights. It could be that the plug to the light was not connected. I would also look for a missing or corroded ground attachment. Often when more than doesn't work, it is the ground.
__________________
Teamfoxy
2005 Itasca Spirit 24V
Sebastian, Florida
Teamfoxy is offline   Reply With Quote
Old 03-28-2019, 09:29 AM   #3
Winnebago Master
 
Join Date: Oct 2017
Location: Elk Grove, CA
Posts: 1,342
My guess is that your spectacular failure resulted in a failed ground connection that's common to the lights in question (although it could be multiple ground failures). Alternatively, the fault could be in the power side but it would have to be ahead of all switches, etc. since the lights have different functions.

You can check this with a multimeter to see if there's power but no ground to these lights. If you're lucky this will be an easy fix.

Here's a link to the wiring diagrams for more info:

https://www.winnebagoind.com/diagram..._e35b_wire.htm
__________________
Bob C
2002 Itasca Suncruiser 35U
W20 Chassis
BobC is offline   Reply With Quote
Reply

Tags
brake, light


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nothing but head, brake, and turn signal lights tombracken Electrical | Charging, Solar and Electronics 5 09-24-2018 07:52 AM
Cracked turn signal light pokgunner Electrical | Charging, Solar and Electronics 8 05-30-2015 10:21 AM
Brake light function seperate turn signal lights. briankstan Running Gear, Axles, Brakes, Wheels and Tires 11 08-12-2014 08:08 AM
No Brake light signal on 7 pin connector rshackleford Running Gear, Axles, Brakes, Wheels and Tires 27 05-07-2013 08:24 PM
location of turn signal flasher Tuna Electrical | Charging, Solar and Electronics 9 05-07-2007 03:01 PM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:50 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.