Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-17-2020, 01:02 PM   #1
Winnebago Watcher
 
Join Date: Aug 2020
Posts: 2
Just Joined 2012 Era having generator problems

Unfortunately, my ERA has been sitting for a while. I am trying to get the generator to kick on. Propane level is at 3/4, battery is at 2/3. I primed by hitting the start button a couple of times. It will not turn over to run.
rphsbusiness is offline   Reply With Quote
Old 08-17-2020, 05:18 PM   #2
Winnebago Master
 
Join Date: Nov 2018
Location: Pflugerville/Austin, Tx
Posts: 2,030
Basic thought is that no need to question the fuel if the generator is not turning over, so that puts it into an electrical question.
Step one is the RV engine starting as normal and was it running when you tried to crank the generator? Was something done to keep the start battery charged while not being used? A dead start battery will often not let the generator start either. Best to alway start the RV engine first as it can then provide power from it's alternator to help start the generator.
__________________
Richard
2015 Winnebago Vista 31KE on 2014 chassis
Morich is online now   Reply With Quote
Old 08-23-2020, 12:50 PM   #3
Winnebago Watcher
 
Join Date: Aug 2020
Posts: 2
Thank you Richard. That was the problem.
rphsbusiness is offline   Reply With Quote
Old 08-23-2020, 02:45 PM   #4
Winnebago Master
 
Join Date: Nov 2018
Location: Pflugerville/Austin, Tx
Posts: 2,030
Good deal. I'm kind of like the blind sow? Can find a nut once in a while even if blind!!
Point to keep in mind is that if the battery goes totally flat during storage and stays for too long it can be damaged, so best to notlet it happens too often and kind of watch that battery a bit more, so it doesn't catch you at the wrong time and place.
I keep a charger on the coach battery to save them but also added a small item called a "Trik-L-Start to let a tiny bit of power move from the coach batteries to keep the start one up. Kind of an automatic one way gizmo that seemed worth adding to avoid having to keep charge on two strings.
__________________
Richard
2015 Winnebago Vista 31KE on 2014 chassis
Morich is online now   Reply With Quote
Reply

Tags
ems, generator, problems


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Just Joined - New Vista Owners DCMac Welcome Mat 3 04-16-2019 01:43 PM
Just joined Daniels621 Welcome Mat 0 04-07-2018 08:34 AM
Just Joined Hockeyjeff Welcome Mat 1 03-18-2018 08:26 PM
Just joined Bradly Welcome Mat 1 03-15-2018 06:54 PM
Tennessee has joined with Era Jefscott Winnebago General Discussions 1 11-01-2017 05:24 PM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 04:48 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×