Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-11-2020, 07:24 AM   #1
Winnebago Camper
 
Join Date: Mar 2018
Location: Etters, Pa
Posts: 6
Aspect 30J 2015 clearance ligts are not working

Hello My name is Rob Im new to the Winnebago community. I have a 2015 aspect 30J and it failed inspection due to the clearence lights not working and also the side marker light on the driver side is not working also. A little history I did noting this during the summer of 2019 that the clearance light when working were very dim? From time to time they were not working and than the next time I checked they were on but very dim.
I found the common ground connection on the back drivers side of the frame and ohmed it out and both sets of ground have continuity.
Has anyone else had this issue and what was your fix?
Thanks
GoAspect is offline   Reply With Quote
Old 01-11-2020, 11:27 AM   #2
Winnebago Owner
 
Join Date: Feb 2019
Location: Flagstaff, AZ
Posts: 141
Rob, it sounds like an intermittent ground. Were you able to follow the wiring from lamp back? Grounds can be frustrating to find. I haven't had the problem on my Aspect but did on my truck. After several hours, I took it to my mechanic and paid him the $200 to find and fix it. I'm not aware of this being a problem on the Aspects, but you might try going over to the Aspect site and ask those guys. They have some "old timers" that are pretty sharp! https://aspectcambriarvforum.forumotion.com

Al
__________________
2017 Aspect 30J
Traveling with Beans our 10# Chi-Weanie!
AZAspect is offline   Reply With Quote
Old 01-11-2020, 03:32 PM   #3
Winnie-Wise
 
akeagle's Avatar
 
Join Date: Mar 2018
Posts: 461
You might consider popping the covers off the lights and pull the bulbs, checking for dirt or corrosion. I once had a single clearance light that failed to work and while checking the bulb I noticed both bulb and fixture electrical connections were slightly corroded. Cleaned both with electrical contact cleaner and a touch with a Dremel wire brush, re-assembled everything, and it worked as advertised.

Next time I need to do that I'll go an extra step to prevent future corrosion by using a little di-electric grease during the re-assembly.

It may be unlikely that ALL of your clearance lights would have corrosion problems, but since your rig is a several years old, its a possibility.
__________________
2016 Minnie Winnie 27Q on a 2015 Ford E450 chassis. Retired U.S. Air Force. Living in Anchorage, Alaska
akeagle is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with Aspect 30J AzLady Winnebago Class C Motorhomes 6 05-22-2018 12:55 PM
Clearance/Tail Lights Not Working jdobbs Electrical | Charging, Solar and Electronics 7 02-04-2017 02:33 PM
About to pull the trigger....2015 Aspect 30J crh97 Winnebago Class C Motorhomes 16 11-19-2014 05:26 PM
Aspect 30j holding tank flush out hermb Winnebago Class C Motorhomes 7 11-26-2013 06:52 AM
HWH Jacks working, not working and working again? Bob&Pat General Maintenance and Repair 6 06-08-2006 04:22 AM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 01:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×