Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-28-2007, 03:07 PM   #1
Winnebago Owner
 
afrank1971's Avatar
 
Join Date: Oct 2006
Location: Southern CA
Posts: 75
Has anyone had any experience with Xantrex customer service? I had an RS2000 installed in my Journey about a month ago, went to go for our first trip with the new inverter this last weekend and the inverter would not recognize AC coming in, from shore or the generator (so no way to charge the batteries). Waited for about 30 minutes on hold with Xantrex to get a tech, he ran me through some things, said yes it seems it's bad, he asked that I disconnect it from AC and DC for 45 minutes then plug it back in, if it's still doing it, then it's bad. Did all that, it's still bad. Now, the RV place that installed it has had it for a week and a half, they were able to get a hold of Xantrex once, and they wanted them to run all the same tests they had me run, they did, same results, now they can't get a hold of Xantrex again. I called, again, waited literally 30 minutes or so before I could talk with someone, told him the whole story, he said he'd get back to me and the RV place tomorrow, he has not, RV place has not heard from them, nor have I. I thought Xantrex was supposed to be the best, both product and support. But I am not having good luck so far. Anyone else have such luck with Xantrex?
__________________
2008 Newmar Kountry Star 3943
2008 Jeep Rubicon Unlimited
afrank1971 is offline   Reply With Quote
Old 08-28-2007, 03:07 PM   #2
Winnebago Owner
 
afrank1971's Avatar
 
Join Date: Oct 2006
Location: Southern CA
Posts: 75
Has anyone had any experience with Xantrex customer service? I had an RS2000 installed in my Journey about a month ago, went to go for our first trip with the new inverter this last weekend and the inverter would not recognize AC coming in, from shore or the generator (so no way to charge the batteries). Waited for about 30 minutes on hold with Xantrex to get a tech, he ran me through some things, said yes it seems it's bad, he asked that I disconnect it from AC and DC for 45 minutes then plug it back in, if it's still doing it, then it's bad. Did all that, it's still bad. Now, the RV place that installed it has had it for a week and a half, they were able to get a hold of Xantrex once, and they wanted them to run all the same tests they had me run, they did, same results, now they can't get a hold of Xantrex again. I called, again, waited literally 30 minutes or so before I could talk with someone, told him the whole story, he said he'd get back to me and the RV place tomorrow, he has not, RV place has not heard from them, nor have I. I thought Xantrex was supposed to be the best, both product and support. But I am not having good luck so far. Anyone else have such luck with Xantrex?
__________________
2008 Newmar Kountry Star 3943
2008 Jeep Rubicon Unlimited
afrank1971 is offline   Reply With Quote
Old 08-28-2007, 03:12 PM   #3
Winnebago Owner
 
Gary the Wombat's Avatar
 
Join Date: Jun 2006
Location: Lake Berryessa, CA
Posts: 208
I haven't had to deal with them myself, but if your experience was mine, it would be time to go over "customer service's" head and talk to a manager/owner. Are you able to get a phone number for corporate headquarters?
__________________
2007 Winnebago 26P

Jeep Wrangler
Gary the Wombat is offline   Reply With Quote
Old 08-28-2007, 03:27 PM   #4
Winnebago Master
 
John_Canfield's Avatar
 
Join Date: Jan 2005
Location: Back at the ranch
Posts: 2,041
I had pretty good luck talking with Xantrex when I had installation questions two years ago. A few months ago I had a problem with the RS2000 getting confused about the charge status - it would think we are in bulk charge and the batteries were really in float (fully charged.)

No trouble getting to talk with a tech. He asked about our software version and when he said it was an older version, he said I had to get it upgraded to move on to the next troubleshooting phase.
__________________
--John

2005 Horizon 40AD, 2005 Jeep Liberty CRD
John_Canfield is offline   Reply With Quote
Old 08-29-2007, 03:36 AM   #5
Winnebago Owner
 
afrank1971's Avatar
 
Join Date: Oct 2006
Location: Southern CA
Posts: 75
I really don't intend for this post to be nothing more than bad mouthing Xantrex, but just venting a bit I guess. I should note that when I get a hold of people, they are, or seem to be, quite helpful. I just can't believe that they have so few technicians that unless you have the patience and time to sit and listen to hold music for a half an hour, you'll never get through. John, when you contacted them, was the wait that bad?
__________________
2008 Newmar Kountry Star 3943
2008 Jeep Rubicon Unlimited
afrank1971 is offline   Reply With Quote
Old 08-30-2007, 06:31 AM   #6
Winnie-Wise
 
vicsryd's Avatar
 
Join Date: Apr 2005
Location: Vancouver, Washington
Posts: 383
Send a message via Yahoo to vicsryd
Sounds similar to my experience when my Link20 went bad.

I learned though if you submit a support inquiry on-line first it goes a long way to speed up the rest of the process. But even the on-line process is a little obtuse as they first have you enter only your email address so they can your a validation email. From the validation email you can open your trouble ticket.

The other catch is if you get a support person admitting a unit is bad (i.e. as in your first call described above) then YOU need to request an RMA number right then and there. It seems to me they won't automatically offer it. And here again the RMA process is obtuse. They give you an RMA number and address to ship to but first you must write the RMA number on your original invoice and fax a copy to a special number they give you over the phone (604-422-2756 is the number they gave me).

Not the easiest customer service model around but it gets the job done if you play the system right.
__________________
Vicki & Jon Pritchard
05 Journey 34H - CAT C7 - Toyota RAV4
3 doxies, 1 chihuahua - WIT, Escapees, FMCA

vicsryd is offline   Reply With Quote
Old 08-30-2007, 02:50 PM   #7
Winnebago Master
 
John_Canfield's Avatar
 
Join Date: Jan 2005
Location: Back at the ranch
Posts: 2,041
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Alan Frank:
--snip-- John, when you contacted them, was the wait that bad? </div></BLOCKQUOTE>Alan - I don't remember it being that bad of a wait but the incident was last summer and I've slept since then.
__________________
--John

2005 Horizon 40AD, 2005 Jeep Liberty CRD
John_Canfield is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Winnebago customer service comes through Clay L Winnebago General Discussions 6 11-18-2008 06:50 AM
HWH Customer Service - BRAVO VectraDon General Maintenance and Repair 11 02-01-2007 06:20 AM
Winnebago Customer Service & The Lodge Alfred622 Winnebago General Discussions 6 12-03-2006 05:31 PM
You gotta love Winnebago Customer Service Warpath Winnebago General Discussions 11 10-24-2006 08:44 AM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:41 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.