Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-25-2016, 08:09 PM   #1
Winnebago Watcher
 
Join Date: Aug 2016
Location: Texas
Posts: 3
Arrow Help Wanted With Jack problem

We have an itasca Cambria 31 and are having trouble with the jacks. They worked fine and now they are stuck. One yellow light on right side bu raise right button stays on. Also under coach the red lights are all on and 1 is blinking. We just recently traded to downsize but the 5th wheel was no problem whatever. Winnebago is know for it's product but oh, my? Any suggestions?
neel2270 is offline   Reply With Quote
Old 10-26-2016, 01:53 PM   #2
Winnebago Camper
 
krivanj's Avatar
 
Join Date: Oct 2009
Location: Fort Pierce, FL
Posts: 13
To get help, you might add if this coach is new or used, and what year. Also give the manufacturer of the jacks, as there are several manufacturers and the symptoms will be different.
One suggestion I have is to call the jack manufacturer and ask for their advice. I have found that whoever made the component will be usually happy to help with questions and problems over the phone.
Hope that helps...
__________________
[SIGPIC][/SIGPIC]Revolution LE 38X C9 Cat
2011 Scion TC toad
1985 KLR 600 as a backup...
krivanj is offline   Reply With Quote
Old 10-26-2016, 05:48 PM   #3
Winnebago Owner
 
Indy Itasca's Avatar
 
Join Date: Dec 2006
Location: Indianapolis Indiana
Posts: 124
Are you sure the emergency brake is set? If the brake is not on the jacks won't work.
__________________
2007 Itasca Sunrise 35L W22 Chassis TigerTrak ScanGaugeII
Blue Ox tow bar - Brake Buddy
2013 Equinox
Indy Itasca is offline   Reply With Quote
Old 10-27-2016, 05:38 AM   #4
Winnebago Watcher
 
Join Date: Aug 2016
Location: Texas
Posts: 3
Help wanted with Jack problem

It is Itaska Cambria 2011. We bought it used and it had a slightly bent Jack on upper drivers side that was replaced and worked fine for 2 outings. HWH Brake control but when I called them they are 3 weeks behind on returning calls! I sent email thinking I would get better response. I called Lichtsinn( so nice) where I had bought a few things and they suggested checking brake switch. Fuses seem to be OK but found connection wire behind fuse box that is loose but never could get the jacks to respond to that fix. I assume brake switch goes bad and will not show when park brake is on? Oh, and yes I had the park/emergency brake set. Could it be brake fluid? Just thought of that.
Another question. Lichtsinn said to always have the motor running when putting the jacks down but manual says cut engine and have in accessory? Will they extend while engine is running? I always did what the manual said do.
neel2270 is offline   Reply With Quote
Old 10-29-2016, 03:26 PM   #5
Winnebago Camper
 
kb2ztx's Avatar
 
Join Date: Apr 2015
Location: Upstate NY
Posts: 36
Sorry can't tell by your posts, but is your issue with getting the jacks to go down aka level the camper or back in after being deployed ? If its trying to level after getting set up one thing i learned is the jacks go the opposite way of the arrow...arrow up meant jack down aka camper up. Took me a few minutes to figure this out. As for running or off I have always done it with the vehicle running. The hydraulics use alot of power so running will help keep the battery charged.
__________________
2003 Winnebago Adventurer 35U
2009 JK
kb2ztx is offline   Reply With Quote
Old 10-30-2016, 10:40 AM   #6
Winnebago Watcher
 
Join Date: Aug 2016
Location: Texas
Posts: 3
We have tried to get them to move either way and nothing. We cancel in between hitting the switch. And yes, we are trying to get them to go down to level. Thank goodness the. Slabs have been level so far but .......
Thank we are hiring up and going in for repair soon. Getting discussed! Neither of us are very mechanical so I guess we will let someone else do the thinking.
neel2270 is offline   Reply With Quote
Old 10-30-2016, 01:30 PM   #7
Winnebago Camper
 
kb2ztx's Avatar
 
Join Date: Apr 2015
Location: Upstate NY
Posts: 36
ours take a bit to go down and you need to hold the button all the way. Ours is not an auto level. Do you hear a motor run when holding the button in ? You should hear the motor run.
__________________
2003 Winnebago Adventurer 35U
2009 JK
kb2ztx is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help Wanted On Leveling a 22R mbs67 General Maintenance and Repair 6 11-02-2016 06:19 AM
If I wanted to replace the OEM patio awning... Richard 34A General Maintenance and Repair 10 01-28-2008 01:50 PM
We're About to Leave!! Last Minute Advice Wanted BigTrace Winnebago General Discussions 28 02-22-2006 12:52 PM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:07 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.