Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-21-2006, 03:28 PM   #1
Winnebago Camper
 
Join Date: Dec 2004
Posts: 41
Today my 2004 Vectra died in the middle of a major highway! No electricity, no hazard lights, no movement. Just sitting in the middle of the road. 911 to the rescue. After 20 minutes and just before the tow arrived, it started. Off the road safely. Turned on the headlights - died again. Waited 10 minutes, started, drove to garage. The mechanic said the primary battery ground - to chassis- was rusted and didn't look good. He cleaned it off added new hardware, thightened everything and set me home. Solved? I don't know.

Does this sound familiar to anyone?
__________________
Don "VectraDon" Thimas

2004 Vectra 40AD
VectraDon is offline   Reply With Quote
Old 08-21-2006, 03:28 PM   #2
Winnebago Camper
 
Join Date: Dec 2004
Posts: 41
Today my 2004 Vectra died in the middle of a major highway! No electricity, no hazard lights, no movement. Just sitting in the middle of the road. 911 to the rescue. After 20 minutes and just before the tow arrived, it started. Off the road safely. Turned on the headlights - died again. Waited 10 minutes, started, drove to garage. The mechanic said the primary battery ground - to chassis- was rusted and didn't look good. He cleaned it off added new hardware, thightened everything and set me home. Solved? I don't know.

Does this sound familiar to anyone?
__________________
Don "VectraDon" Thimas

2004 Vectra 40AD
VectraDon is offline   Reply With Quote
Old 08-21-2006, 05:06 PM   #3
Registered User
 
glenda1908's Avatar
 
Join Date: Jun 2004
Location: Virginia Beach, VA
Posts: 396
We have your same coach. Never had something like that happen though. Sounds like the battery issue was the problem. At least that seemed to fix the problem. Have you had an opportunity to use it again to see if things were okay?
glenda1908 is offline   Reply With Quote
Old 08-22-2006, 04:05 PM   #4
Winnebago Camper
 
Join Date: Dec 2004
Posts: 41
We haven't driven far yet but everything seems OK. A long trip later this week will be the true test. I'll report when we get back.
__________________
Don "VectraDon" Thimas

2004 Vectra 40AD
VectraDon is offline   Reply With Quote
Old 08-23-2006, 03:22 PM   #5
Winnebago Camper
 
Join Date: Dec 2004
Posts: 41
Getting ready for a trip. Sitting in the yard all clean and preped. All seems well until I turn on the headlights. ENGINE DIES. Start again, directionals...Engine dies.

Called Freightliner. "Could be the headlight control module" Appointment for service a week away.

To be continued ...
__________________
Don "VectraDon" Thimas

2004 Vectra 40AD
VectraDon is offline   Reply With Quote
Old 08-23-2006, 03:52 PM   #6
Administrator Emeritus
 
Join Date: Dec 2003
Location: Virginia Beach, VA
Posts: 1,319
Don, I owned a 2006 Vectra for six months....turn signal cams got so I could activate and cancel them with the ICC headlight switch on the steering wheel...When I used turn signals the NAV screen brightened and then dimmed...
Keep plugging along and you'll have a good coach one day.
rebelsbeach is offline   Reply With Quote
Old 09-21-2006, 05:37 PM   #7
Winnebago Camper
 
Join Date: Dec 2004
Posts: 41
Well, the problem has been solved. Bolted to the chassis, is a 135 amp circuit breaker. This circuit breaker is on the line between the battery pack and the starter and front-end electrics. Mine was badly corroded, rusty and shorted out. It's worth taking a look at and spraying with an anti-corrosive. I found it behind the left compartment with the shore power/inverter equipment. Too bad they didn't put it in a location not exposed to water, dirt and salt (I live in the Northeast).

What I've learned from this is - more attentio need to be given to cleaning the places you can't see, adding rust proofing, and spraying anti-corrosion spray on most of the undercarriage of the Vectra.

What you can't see - WILL HURT YOU!
__________________
Don "VectraDon" Thimas

2004 Vectra 40AD
VectraDon is offline   Reply With Quote
Old 09-21-2006, 06:26 PM   #8
Winnebago Master
 
cbeierl's Avatar
 
Join Date: Aug 2005
Location: Nashua, NH
Posts: 1,774
Hi Don,

Any chance of taking a picture of that circuit breaker and its location?
__________________
Chris Beierl

2005 Winnebago Vectra 36RD
cbeierl is offline   Reply With Quote
Old 09-24-2006, 10:25 AM   #9
Winnebago Camper
 
Join Date: Dec 2004
Posts: 41
I'll try to attach a couple I took to this note. Hope it works. I found my circuit breaker behind the compartment that houses the shore power reel.

Sorry It won't paste into this document. I can email it to you if you like. [email protected]
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by cbeierl:
Hi Don,

Any chance of taking a picture of that circuit breaker and its location? </div></BLOCKQUOTE>
__________________
Don "VectraDon" Thimas

2004 Vectra 40AD
VectraDon is offline   Reply With Quote
Old 09-24-2006, 11:25 AM   #10
Administrator Emeritus
 
Join Date: Dec 2003
Location: Virginia Beach, VA
Posts: 1,319
Don,
If you would upload your pic to the internet you could then post it here...

If you have no way of posting a pic to the internet we have a free photo gallery which you can join and then upload the photo....Once it's uploaded all you do is copy and paste the photo's URL..

Many folks that join our photo site simply use the same login and password you use for the forums.

Hope that helps!
rebelsbeach is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ELECTRICAL OUTLET/TV PROBLEM - SERVICE CENTER CAUSED emmmw Electrical | Charging, Solar and Electronics 7 12-14-2008 06:54 AM
electrical problem SeaRay Electrical | Charging, Solar and Electronics 6 09-04-2007 11:32 AM
Electrical problem with Jacks FrankO General Maintenance and Repair 8 08-24-2007 12:58 AM
Electrical problem or operator error. resqguy Electrical | Charging, Solar and Electronics 23 09-11-2005 05:46 AM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 12:58 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
×