Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-28-2011, 03:45 PM   #1
Winnebago Owner
 
Ron & Dee's Avatar
 
Join Date: Apr 2005
Location: FL
Posts: 201
Kwikee Step problem

Steps extended and wouldn't retract, then they started working ok for a few times, now the are stuck in and won't extend.

Where do I start trouble shooting?

Thanks,

Ron
__________________
2002 32' Adventurer 8.1 Workhorse no toad
Our 2 Girls,Sweetie Pie & Shadow
Florida
Ron & Dee is offline   Reply With Quote
Old 08-28-2011, 07:16 PM   #2
Lit
Winnebago Watcher
 
Lit's Avatar
 
Join Date: Feb 2010
Location: Ohio
Posts: 3
Yesterday I had just about the same problem, I was thinking the battery died on me and was going to charge it. Today I went back and checked the voltage it was less then 12 volts, my battery charger registered a fault. I took it out and had a shop check it out. Turns out I had one bad cell.
__________________
Lit
2005 Dolphin
2012 Equinox
Lit is offline   Reply With Quote
Old 08-28-2011, 07:54 PM   #3
Winnebago Camper
 
Join Date: Jun 2011
Location: lakkeland Fl
Posts: 5
Hi Ron & Dee , I had a simular problem . I took apart the little contact switch on the bottom of the door ( right side ) and cleaned it up abit . The steps worked fine , but make sure you batteries are charged . When my steps went in and out without opening the door , I thought somebody was tricking me. lol . Have a good one.. Tommy Tucer Lakeland Fl.
tommy tucer is offline   Reply With Quote
Old 08-28-2011, 09:21 PM   #4
Winnebago Camper
 
texnet's Avatar
 
Join Date: Apr 2009
Location: Granbury, Texas
Posts: 35
This is the link to owners manuals http://www.kwikee.com/Adocuments.html#steps, which contain troubleshooting procedures. You just need to figure out which step you have.

This is the one that I have on my 2003 Monaco, which may be the same one for your coach since it is a 2002. http://www.kwikee.com/PDFDocuments/880OwnerManual.pdf
__________________
Ronnie (WD5GIC) & Jan (WD5IHU)
2003 Monaco Dynasty Countess 42' w/tag, 2012 Ford Flex
http://www.ronniesphotos.com

texnet is offline   Reply With Quote
Old 08-29-2011, 07:25 AM   #5
Winnebago Owner
 
Ron & Dee's Avatar
 
Join Date: Apr 2005
Location: FL
Posts: 201
I haven't had time to do much trouble shooting yet, but the batteries are new, the door switch is ok, and the circuit breaker for the step us not tripped. The light under the steps works, coming on and off with the door opening and closing.

Are there any other fuses in the electrical circuit that I can check.

Thanks,

Ron
__________________
2002 32' Adventurer 8.1 Workhorse no toad
Our 2 Girls,Sweetie Pie & Shadow
Florida
Ron & Dee is offline   Reply With Quote
Old 08-29-2011, 11:14 AM   #6
Winnebago Camper
 
fun 33V's Avatar
 
Join Date: Oct 2010
Posts: 40
Our steps started acting up at the ocean the plug at the motor was loose, cleaned the connections and started working properly.
__________________
2005 Itasca 33V Sunrise 8.1 Workhorse W-20
fun 33V is offline   Reply With Quote
Old 08-30-2011, 07:34 AM   #7
Winnebago Owner
 
Ron & Dee's Avatar
 
Join Date: Apr 2005
Location: FL
Posts: 201
UPDATE

Temporary Fix

The old hammer trick, a couple of bangs and they started working

Something is hanging up somewhere The steps started out not retracting, but would retract after slamming the door. At first I thought it was the door switch, but after they started not wanting to extend and the step light was on, I did the hammer bang on the motor and they started working.

Now to find out where the binding is located

Ron
__________________
2002 32' Adventurer 8.1 Workhorse no toad
Our 2 Girls,Sweetie Pie & Shadow
Florida
Ron & Dee is offline   Reply With Quote
Old 08-30-2011, 08:17 PM   #8
Winnebago Watcher
 
Join Date: Mar 2011
Location: Medina, Ohio
Posts: 3
Stuck step

Had the same problem. I was getting power because the light was on, but the step wouldn't extend. The step had worked just minutes ago. Sooo, I took a hammmer and gave a decent rap to the motor. It has worked fine since (about a week). I don't know if it was bond up somehow or the motor is going bad. I'd bet on the later. Good luck!!
DAB2011 is offline   Reply With Quote
Old 09-01-2011, 08:55 AM   #9
Winnie-Wise
 
Join Date: Aug 2004
Posts: 354
I also had the same issue, a wire on the inside STEP toggle switch had pulled out. Quick roadside repair made. Good luck.
Gary CA is offline   Reply With Quote
Reply

Tags
kwikee


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:41 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×