Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-03-2002, 06:12 PM   #1
Winnebago Owner
 
Ghost's Avatar
 
Join Date: Aug 2002
Location: Connecticut Woods
Posts: 75
I've tried three or four times now to get the compubroil to work right in the Sharp convection oven. It preheats for a LONG time - so far I've only waited 25 mins max.

Same for regular broil - it never finishes pre-heating.

Tonight I had been cooking with convection at 400 f and then went straight to Compubroil/Broil and the danged thing still wanted preheat forever. Just cooked the steaks while it said it was preheating. Took 15 minutes... argh!

Ghost
'02 Adventurer 32V Ford
Various Toads
Connecticut Woods
FMCA 300790, Good Sam, PCA-CVR
__________________
Ghost
Ghost is offline   Reply With Quote
Old 11-03-2002, 06:12 PM   #2
Winnebago Owner
 
Ghost's Avatar
 
Join Date: Aug 2002
Location: Connecticut Woods
Posts: 75
I've tried three or four times now to get the compubroil to work right in the Sharp convection oven. It preheats for a LONG time - so far I've only waited 25 mins max.

Same for regular broil - it never finishes pre-heating.

Tonight I had been cooking with convection at 400 f and then went straight to Compubroil/Broil and the danged thing still wanted preheat forever. Just cooked the steaks while it said it was preheating. Took 15 minutes... argh!

Ghost
'02 Adventurer 32V Ford
Various Toads
Connecticut Woods
FMCA 300790, Good Sam, PCA-CVR
__________________
Ghost
Ghost is offline   Reply With Quote
Old 11-03-2002, 06:17 PM   #3
iRV2 Marketing
 
DriVer's Avatar
 
Join Date: Jan 2000
Location: Conway, SC
Posts: 886
Although we have the same Sharp Convection Oven, I'm not sure I know what you mean by Compu-Broil. Maybe I ain't got one of those

I know we've used the regular Broil settings and they seem to work OK.

By the way what do you use to clean the stainless interior of the oven? I am very reluctant to use products like Easy-Off.

01 Winnebago/Workhorse Model 37G/W20 Adventurer
02 Chevrolet TrailBlazer LS
Nor'Easters
"We Will Never Forget"
8 8
__________________
03 Adventurer 38G, Workhorse W22
F&R Track Bars, Safety+ , Ultrapower, Taylor Extremes, SGII
TST 507, Blue Ox, SMI, Koni FSD, CrossFire
RV/MH Hall of Fame - Lifetime Member
DriVer is offline   Reply With Quote
Old 11-03-2002, 06:21 PM   #4
Winnebago Owner
 
Ghost's Avatar
 
Join Date: Aug 2002
Location: Connecticut Woods
Posts: 75
Bottom right hand side of control console - little gray button for "Compubroil" - hit #3 for steak.

So far we just use soap, water, scotchbrite pad (except on the sensor in the roof & glass surfaces)& elbow grease. Like you, we are apprehensive about using any standard oven cleaners - book says not to...

Ghost
'02 Adventurer 32V Ford
Various Toads
Connecticut Woods
FMCA 300790, Good Sam, PCA-CVR
__________________
Ghost
Ghost is offline   Reply With Quote
Old 11-03-2002, 07:20 PM   #5
Winnebago Camper
 
Winnobego's Avatar
 
Join Date: Aug 2002
Location: Antioch, Ca
Posts: 11
Hey Ghost I would suggest going to the store and buying a Weber Sumit 650. Zero to 800 in about 10 mins. But it will cook a pork roast all day if you need to.

http://www.weber.com/Public_Weber/gr...l_detail_2.asp

It also comes in LP too......

Bob, Vicki and the Boyz, Two Cats, Two Dogs, One Bird and one over loaded Winnebago
__________________
https://banners.wunderground.com/banner/gizmotimetempbig_both/language/www/US/CA/Antioch.gif[/img]

Winnobego is offline   Reply With Quote
Old 05-15-2006, 09:11 AM   #6
Winnebago Watcher
 
Jimbo8264's Avatar
 
Join Date: Jun 2001
Location: Glenville, New York
Posts: 2
We tried to use compubroil and oven would not preheat after 45 min. Finally went out and used the gas grill. <BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Ghost:
I've tried three or four times now to get the compubroil to work right in the Sharp convection oven. It preheats for a LONG time - so far I've only waited 25 mins max.

Same for regular broil - it never finishes pre-heating.

Tonight I had been cooking with convection at 400 f and then went straight to Compubroil/Broil and the danged thing still wanted preheat forever. Just cooked the steaks while it said it was preheating. Took 15 minutes... argh!

Ghost
'02 Adventurer 32V Ford
Various Toads
Connecticut Woods
FMCA 300790, Good Sam, PCA-CVR </div></BLOCKQUOTE>
__________________
"MEANDERING TO A DIFFERENT DRUMMER"

Jim (KC2JJQ) & Sally
Jimbo8264 is offline   Reply With Quote
Old 05-15-2006, 02:34 PM   #7
Winnebago Owner
 
Ed Gardiser's Avatar
 
Join Date: Feb 2006
Posts: 93
Not to ask a stupid question why would you want to broil anything inside the motorhome, food smell, plus the mess it will make inside the convection/microwave.A outdoor Grilled steak is hard to beat.
Ed Gardiser
Escondido,Ca.
04 Vectra
87 Nissan PickUp
FMCA
Ed Gardiser is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 10:57 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
×