Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-09-2007, 07:10 AM   #1
Winnebago Owner
 
Lindsay Richards's Avatar
 
Join Date: Dec 2007
Location: Tavares, FL
Posts: 82
We we just brought back our 2004 Itasca Suncruiser 33 V, I noticed that the cruise control wasn't working. I have a Workhorse and Chevy 8.1. The controls were just like my old 464 coach and I have check the fuse and it is OK. Any ideas???
Lindsay Richards is offline   Reply With Quote
Old 12-09-2007, 07:10 AM   #2
Winnebago Owner
 
Lindsay Richards's Avatar
 
Join Date: Dec 2007
Location: Tavares, FL
Posts: 82
We we just brought back our 2004 Itasca Suncruiser 33 V, I noticed that the cruise control wasn't working. I have a Workhorse and Chevy 8.1. The controls were just like my old 464 coach and I have check the fuse and it is OK. Any ideas???
Lindsay Richards is offline   Reply With Quote
Old 12-09-2007, 11:09 AM   #3
Winnie-Wise
 
bruceh's Avatar
 
Join Date: Aug 2007
Location: Coarsegold, CA
Posts: 260
Keep fooling with it. It doesn't work the same way as other vehicles.

I have a 95 Suburban with identical controls (and instrument panel) and am constantly irritated because they don't work the same. It might have somethng to do with the 'drive by wire' trhottle control.

One idea!

You could also check the brake switch to make sure that it is adjusted properly.
__________________
2001 Winnebago Adventurer, 35U, W-20 8.1
F+R Trac bars, F+R sway bars, SafTsteer, F Sumo Springs, 4 Koni FSDs
bruceh is offline   Reply With Quote
Old 12-09-2007, 01:29 PM   #4
Winnebago Owner
 
Join Date: Oct 2003
Location: Solon, Ohio USA
Posts: 134
Send a message via ICQ to W8RLM
Another easy check is the brake pedal switch. If it is not adjusted properly, your brake lights will be on, and this disengages the cruise control.

Try pulling up on the back of the brake pedal while you are driving and engaging the cruise control. If it works, then you found your problem. The brake pedal switch needs to be adjusted.

Hope it helps.

W8RLM - Bob

W8RLM - Bob
__________________
2006 Winnebago Journey, Model 39K, 2013 Dodge Dart
W8RLM is offline   Reply With Quote
Old 12-09-2007, 04:14 PM   #5
Winnebago Master
 
"007"'s Avatar
 
Join Date: Oct 2004
Posts: 629
Here is a old thread about CC and brake switch problems. Cruise Control
It may help you.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 12-10-2007, 11:29 AM   #6
Winnebago Owner
 
Lindsay Richards's Avatar
 
Join Date: Dec 2007
Location: Tavares, FL
Posts: 82
We took the new coach over to get the tow bar and Toad Stop hooked up and low and behold, I got the cruise control working. Like you said, just keep fooling with it. Have to hold in the button down for about 5 seconds and the dash light comes on and we were cruising. Tried it many times and it works. On my 464 took only a tap to activate. Pilot error once agin. I did gain some knowledge on my fuse system fooling with it though. This basement air is unbelievable. I can hang meat in here after 15 minutes.
Lindsay Richards is offline   Reply With Quote
Old 03-05-2008, 05:42 PM   #7
Winnebago Watcher
 
Join Date: Jan 2008
Posts: 2
Check the stop light bulbs. If one is burned out the cruise will not work.
jerryrk is offline   Reply With Quote
Old 03-05-2008, 06:21 PM   #8
Winnebago Master
 
"007"'s Avatar
 
Join Date: Oct 2004
Posts: 629
jerryrk welcome to the forum.
Thanks for your input to the forum, enjoy the forums and do post often, ever in need of KARMA just say the word.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise Cruise Not Maintaining Speed ep35rja Winnebago General Discussions 9 05-24-2006 10:58 AM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 01:27 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×