Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-14-2018, 01:21 PM   #1
Winnie Vectra Full Timer
 
TenMillie's Avatar
 
Join Date: Jul 2017
Posts: 16
Fixed it but broke it again

2004 Vectra 40kd
Atwood water heater
My hot water heater stopped putting out any water at all. Thanks to this forum and IRV2 I found out it was the check valve. Got a new one and replaced the old one. That fixed the no water problem but in the process I hit the box covering the electrical connections on the back side causing a spark. Now the hwh does not work on the electrical side. Works fine on gas.
Can anyone tell me the most likely thing I messed up and where it's located?
I have checked my breakers and the 2amp fuse in front is good.
TenMillie is offline   Reply With Quote
Old 11-14-2018, 03:21 PM   #2
Winnebago Master
 
powercat_ras's Avatar
 
Join Date: May 2015
Location: Manhattan, Kansas USA
Posts: 627
There should be a 4 wire low voltage cable going to the hot water heater.

3 Yellow , 1 white Sorry can't say which yellow is which but you can look at wiring diagrams on WinnebagoInd.com if you don't want to do trial and error

White = Ground

Yellow #1 = 12 volts towards water heater when calling for 120 volt water heater element on

Yellow #2 = 12 volts towards water heater when calling for Propane water heating

Yellow #3 = output from hot water heater, 12 volts out only when there is a problem with propane water heating, where the flame did not light after 3 tries to spark ignite it. Goes to a fault indicator in or near the propane water heater switch.

If you have a pilot light type water heater you may not have #3.

Good luck.
__________________
Randy - Manhattan, Kansas
2015 Vista 27N
2016 Honda HR-V
powercat_ras is offline   Reply With Quote
Old 11-17-2018, 05:09 AM   #3
Winnie Vectra Full Timer
 
TenMillie's Avatar
 
Join Date: Jul 2017
Posts: 16
Got it fixed!! The white wire inside the black box on back of water heater had come loose.
TenMillie is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
'95 Vectra - WW broke during windshield install JamesT Winnebago Class A Motorhomes 8 12-18-2008 10:46 AM
Long trip, nothing broke! smlranger Campgrounds, Travel and Attractions 11 10-15-2008 05:20 AM
Help I broke a part of my seat Mark Bento General Maintenance and Repair 11 02-22-2008 04:34 AM
Nice - we broke our awning John_Canfield General Maintenance and Repair 25 05-28-2007 03:03 AM
LR Slide Broke Vet Man General Maintenance and Repair 10 10-06-2005 12:36 PM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:11 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×