Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-10-2019, 01:46 AM   #1
LetsCook
 
Join Date: Jun 2019
Posts: 1
Allison 4 speed tranny question

I just purchased a 1999 Winnebago Vectra GT with an Allison 4 speed transmission from a private seller. I noticed when I run at about 60mph, the RPM's hover around 3000. Is this normal? Thanks for any help/info!
LetCook is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tranny temp gauge rjsracing Winnebago Class A Motorhomes 6 02-23-2018 05:59 PM
Tranny went out today FDC General Maintenance and Repair 13 09-08-2012 08:06 PM
Allison Tranny Temp Check? Ustamiata Winnebago General Discussions 6 11-09-2008 09:15 AM
Tranny fluid PM bobpie General Maintenance and Repair 10 09-21-2007 03:25 PM
Allison Trans Question another Winnie mystery GG1 Winnebago General Discussions 6 10-30-2005 03:10 AM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:15 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.