Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-06-2008, 10:43 AM   #1
Winnebago Camper
 
aragu36's Avatar
 
Join Date: May 2008
Location: san bruno ,ca
Posts: 8
I just changed trans fluid and filter and 4th gear seams slugish on hills
any feedback
__________________
1999 WINNEBAGO ADVENTURER 34V
CUMMINS ISB 5.9 275 hp
Allison MT 643
aragu36 is offline   Reply With Quote
Old 06-06-2008, 10:43 AM   #2
Winnebago Camper
 
aragu36's Avatar
 
Join Date: May 2008
Location: san bruno ,ca
Posts: 8
I just changed trans fluid and filter and 4th gear seams slugish on hills
any feedback
__________________
1999 WINNEBAGO ADVENTURER 34V
CUMMINS ISB 5.9 275 hp
Allison MT 643
aragu36 is offline   Reply With Quote
Old 06-06-2008, 02:13 PM   #3
Winnie-Wise
 
vicsryd's Avatar
 
Join Date: Apr 2005
Location: Vancouver, Washington
Posts: 383
Send a message via Yahoo to vicsryd
MT 643 is a 4 speed and 4th gear is 1.00:1 ratio, no overdrive. Only thing I can think of is the lockup torque converter isn't locking up. I don't have any direct experience with this behavior in an Allison but in my old GMC truck the torque converter stopped locking up when the transmission fluid was low and started foaming.

You might try driving it, getting the tranny up to temp and when you feel like it is being sluggish then pull over and check the diptick for both level and any signs of foaming.

There is quite a bit of documentation available for the MT 643 on the Allison web site available here. Unfortunately, all the troubleshooting documentation, including a video, cost $$ to download.
__________________
Vicki & Jon Pritchard
05 Journey 34H - CAT C7 - Toyota RAV4
3 doxies, 1 chihuahua - WIT, Escapees, FMCA

vicsryd is offline   Reply With Quote
Old 06-06-2008, 02:31 PM   #4
Winnie-Wise
 
Pubtym's Avatar
 
Join Date: May 2006
Posts: 359
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by aragu36:
I just changed trans fluid and filter and 4th gear seams slugish on hills
any feedback </div></BLOCKQUOTE>

First question: Did you recheck that the correct tranny fluid and filter were installed?
__________________
Pubtym, 20th SOS "Green Hornet" , Viet Nam 68-69,
2015 Thor A.C.E 29.3
Pubtym is offline   Reply With Quote
Old 06-06-2008, 03:03 PM   #5
Winnie-Wise
 
vicsryd's Avatar
 
Join Date: Apr 2005
Location: Vancouver, Washington
Posts: 383
Send a message via Yahoo to vicsryd
This specs says its 18 quarts.
__________________
Vicki & Jon Pritchard
05 Journey 34H - CAT C7 - Toyota RAV4
3 doxies, 1 chihuahua - WIT, Escapees, FMCA

vicsryd is offline   Reply With Quote
Old 06-06-2008, 08:32 PM   #6
Winnebago Camper
 
hondo12's Avatar
 
Join Date: Mar 2008
Location: Sumner Washington
Posts: 19
I do not have any machanical knowalge about your transmission, but reading you post about 18 quarts to refill, reminded me that I did read in my allison manual that the initial fill was 17 or 18 quarts but when changing oil the amount to refill was 12 or 13 quarts? as all the oil could not be drained through the plug, again just a hunch, check your dip stick when hot.
__________________
2008 Adventurer 38T

Ultra Power program by Brazels
hondo12 is offline   Reply With Quote
Old 06-16-2008, 01:48 PM   #7
Winnebago Camper
 
aragu36's Avatar
 
Join Date: May 2008
Location: san bruno ,ca
Posts: 8
thanks
i went to the allison dealer and he told me to get it up to temp and pull off the
lock up solonoid its just above the pan and thats the right level
im a litte weary but it seems my dipstick is way off im getting no reading with 18 qts



thanks for the help
__________________
1999 WINNEBAGO ADVENTURER 34V
CUMMINS ISB 5.9 275 hp
Allison MT 643
aragu36 is offline   Reply With Quote
Old 06-16-2008, 01:50 PM   #8
Winnebago Camper
 
aragu36's Avatar
 
Join Date: May 2008
Location: san bruno ,ca
Posts: 8
as for the filter i did it myself and bought the parts from the allison dealer
__________________
1999 WINNEBAGO ADVENTURER 34V
CUMMINS ISB 5.9 275 hp
Allison MT 643
aragu36 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Gear (now Lippert) pinion gear shaft bushing failure cruizerEd General Maintenance and Repair 21 03-09-2016 11:23 AM
SMI vs. US Gear toad brake John_Canfield Towing, Hitching and Vehicles 24 08-07-2005 05:37 AM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 10:31 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
×