Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-24-2014, 09:27 PM   #1
Winnebago Camper
 
Join Date: Sep 2013
Location: Altoona, PA
Posts: 6
Fuel gauge drops to empty

Ellipse with Cummings 450. Great unit, but often when driving along fuel gauge drops to empty. If stop and turn engine off then on registers properly. Dealer says being in when happens - the answer when they haven't a clue. Any suggestions?
Shotdoc is offline   Reply With Quote
Old 02-24-2014, 09:43 PM   #2
Winnebago Master
 
Join Date: Sep 2005
Posts: 962
I had a fuel gauge that was erratic ... a friend told me to check the ignition switch .. it was loose ... I figured out how to tighten it ... the erratic fuel gauge problem went away.

It may not be your ignition switch ... but it sounds to me like you have a loose connection ... probably a ground ... someplace.
skigramp is offline   Reply With Quote
Old 02-25-2014, 08:18 PM   #3
Winnebago Camper
 
Join Date: Jul 2011
Posts: 49
Quote:
Originally Posted by Shotdoc View Post
Ellipse with Cummings 450. Great unit, but often when driving along fuel gauge drops to empty. If stop and turn engine off then on registers properly. Dealer says being in when happens - the answer when they haven't a clue. Any suggestions?
It's a Freightliner chassis issue. Bad batch of gauges.
See last few posts in this thread: http://www.irv2.com/forums/f26/fuel-...-126658-2.html

Mine has been working fine since replacement with updated gauge thousands of miles and many tanks of fuel later!

Todd
__________________
Todd
2011 Itasca Ellipse 42QD
74K miles and counting
toddb is offline   Reply With Quote
Old 02-25-2014, 08:22 PM   #4
Winnebago Camper
 
Join Date: Jul 2011
Posts: 49
Quote:
Originally Posted by toddb View Post
It's a Freightliner chassis issue. Bad batch of gauges.
See last few posts in this thread: http://www.irv2.com/forums/f26/fuel-...-126658-2.html

Mine has been working fine since replacement with updated gauge thousands of miles and many tanks of fuel later!

Todd
PS you can pull the top off your instrument panel and get the actual gauge part number of the back and then call Freightliner. They should know what's going on if you have the old or bad gauge and get an updated one out to a FTL dealer near you for replacement.
__________________
Todd
2011 Itasca Ellipse 42QD
74K miles and counting
toddb is offline   Reply With Quote
Old 02-26-2014, 03:57 AM   #5
Winnebago Camper
 
Join Date: Sep 2013
Location: Altoona, PA
Posts: 6
Thanks Todd
Shotdoc is offline   Reply With Quote
Old 02-26-2014, 06:36 AM   #6
Winnebago Owner
 
Join Date: Nov 2011
Location: Florida
Posts: 129
Same issue on our 2011 meridian was a defective gauge. Sounds like a common issue FL should know about it but they gave me the same we have to see it so I recorded it on my phone and they replaced the guage
fla tom is offline   Reply With Quote
Old 02-26-2014, 12:48 PM   #7
Winnebago Camper
 
bertman's Avatar
 
Join Date: Mar 2012
Location: Harrisburg, PA
Posts: 42
Freightliner thought it was a defective sender in the fuel tank. Drained and dropped the fuel tank, replaced sender, still no work! Was a defective guage pack!
__________________
Bob & Deb K.
2012 Itasca Ellipse QD 'Elli'
2010 Buick Enclave AWD Toad 'Ginny'
bertman is offline   Reply With Quote
Old 02-28-2014, 05:45 PM   #8
Winnebago Master
 
jerichorick's Avatar
 
Join Date: Jun 2013
Location: Full-timer/volunteer w/SOWERS
Posts: 2,305
Quote:
Originally Posted by Shotdoc View Post
Ellipse with Cummings 450. Great unit, but often when driving along fuel gauge drops to empty. If stop and turn engine off then on registers properly. Dealer says being in when happens - the answer when they haven't a clue. Any suggestions?
Call FCCC in Gaffney, SC where the chassis is built. Give them you vin. They might have a better handle if the gauge is the issue or something else.

CUSTOMER ASSISTANCE OR CONCERNS
Contact our Customer Support Center at
1-800-FTL-HELP (1-800-385-4357)

They seem to know what is up with their products for the most part.
__________________
Rick & Melissa Young & Dawson (RIP), 2011 Meridian 40U, FL XCL, ISL 380HP/DEF, Al 3000 MH, 2014 Honda CR-V, SMI AF1, Blue Ox TruCenter & tow equip.,EEZTire TPMS.
Servants On Wheels Ever Ready. Best job we ever paid to do . (full time volunteers)
jerichorick is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cab heater temp drops at eng idle, 2013 erniet General Maintenance and Repair 7 11-12-2013 10:52 PM
Generator Drops Offline Thudman Electrical | Charging, Solar and Electronics 13 07-31-2005 06:43 PM
Earnings Off, Winnebago's Stock Drops 3huskies Winnebago General Discussions 7 03-27-2005 05:19 PM
Gas gauge went to empty Winnebago General Discussions 8 12-31-1969 07:00 PM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 01:17 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×