Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-31-2020, 07:38 PM   #1
Winnebago Camper
 
Join Date: Oct 2019
Posts: 11
Jenssen RV 10 RADIO

I have a 2018 Vista LX 30T and the big touch screen Jenssen RV10 radio went bizzark the other day. It started making a popping sound sounded like something on the roof had come loose. I started to pull off the road when I shut off the radio and it stopped. Turned the radio back on and it was clear ability 30 seconds and then it started again. I tried all different bands still did it. I see nothing in the radio instructions about this problem. I tried resetting the radio. Nothing helps, it acts like it's overheating after About 30 seconds then it starts popping. Also noticed the rear speakers are buzzing and distorted.
Jdhargis is offline   Reply With Quote
Old 06-02-2020, 09:12 PM   #2
Proud “No Intent” Owner
 
Wyatt's Avatar
 
Join Date: Jul 2019
Location: Belmont, CA
Posts: 454
Blog Entries: 1
Sounds like it just failed. There are sooo many things it could be. Loose wiring harnesses? That’s the first thing I’d check.
__________________
26 m 2018 Intent Owner with too many upgrades to mention. Seriously...
https://www.winnieowners.com/forums/...albums248.html
Wyatt is offline   Reply With Quote
Reply

Tags
radio


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 04:21 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×