Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-09-2016, 09:15 PM   #1
Winnebago Watcher
 
Join Date: Apr 2016
Posts: 2
Adventurer water pump issue

Just purchased first RV, 2000 Adventurer and cannot get on board water pump to flow. Fresh water tank is full and pump runs but no pressure. Any suggestions would be appreciated.
Thanks
HARLEY FAN is offline   Reply With Quote
Old 08-09-2016, 10:18 PM   #2
Winnie-Wise
 
Skip426's Avatar
 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 339
Welcome to the forum.

Have you accessed the pump to check for the inlet line being hooked up properly?
There could be an inlet filter and if the RV was not winterized properly that filter or the pump housing it's self may be cracked . If any air can get into the pump , it will not prime.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 08-09-2016, 10:25 PM   #3
Member
 
Join Date: Nov 2015
Posts: 55
Check inlet valving at pump and make sure winterizing valve is set to 'tank' vs to open suction tube used for winterizing (tube goes in jug of anti-freeze so pump is used to run anti-freeze thru plumbing lines)

As suggest above......check that pump inlet strainer/housing isn't cracked

Then turn pump ON
Open nearest faucet HOT side.......leave open and it should sputter/blow air.
Will take a while as water heater has to fill first before water can flow from faucet

Let pump run while you check system...........it is designed to run dry so don't worry.
Old-Biscuit is offline   Reply With Quote
Old 08-10-2016, 09:43 AM   #4
Winnebago Camper
 
joemcgin's Avatar
 
Join Date: Mar 2013
Location: Franklin, Mass.
Posts: 40
Also check that the switch in the wet bay is set back to "City Water" if you filled the tank using the input there. Happened to me our first time I filled the water tank there and didn't move that switch back. There's no documtation in the manual about this but the good people here helped me out.
__________________
Joe & Kathy
2000 Winnebago Adventurer 32V Workhorse Chassis
joemcgin is offline   Reply With Quote
Old 08-10-2016, 06:08 PM   #5
Winnebago Owner
 
Join Date: Dec 2015
Posts: 64
Ok, I'll jump in too. All of the above suggestions should get you flowing again, if not can you disconnect the discharge line from the pump itself to determine is it the pump or a downstream problem.
__________________
Tara is our Border Collie daughter.
2014 Winnegabo Forza 34T
Dragging a 2015 Cadillac SRX, very nicely!
TarasParents is offline   Reply With Quote
Old 08-11-2016, 09:07 PM   #6
Winnebago Watcher
 
Join Date: Apr 2016
Posts: 2
Water pump issue

Thank you all for your suggestions and comments. I have placed a bucket of water under the pick up tube used for feeding wnterization fluid through the water system and the pump empties the bucket fairly quickly. I have not let the pump run very long over concern it may be harmful to it doing so. Based on your comments it sounds like I may have not let it run long enough to fill the system. I will give it another try this weekend.
Thanks again!
HARLEY FAN is offline   Reply With Quote
Old 08-11-2016, 09:21 PM   #7
Winnie-Wise
 
Skip426's Avatar
 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 339
The Sure-flow water pump in almost all RVs , is designed to run dry for as long as it takes to prime it's self , it wont do any harm .
You have to make sure no air is being drawn in or it won't prime.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Reply

Tags
vent, water, water pump


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Quiet Water pump for 2003 Adventurer 35U? dunkonu23 Plumbing | Systems and Fixtures 28 06-03-2016 10:16 AM
Water pump forces water out city water ccconsult Plumbing | Systems and Fixtures 8 03-06-2016 10:08 PM
2015 Adventurer 38Q Water Pump Access Kent0826 Winnebago Class A Motorhomes 6 07-13-2014 05:34 PM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 01:25 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
×