Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-09-2022, 08:33 PM   #1
Winnebago Owner
 
Join Date: Sep 2017
Location: Apple Valley, MN
Posts: 128
2005 Journey suddenly lost house dc power

Dry camping and was running generator to run the microwave qnd too off the batteries and everything shut down. Checked all the breakers nothing popped. House voltage on the all-in-one center shows 0 volts. Turn the inverter on and the displays shows 12.4 volts and if I turn the inverter on the ac outlets work. Cant start the generator even when using battery boast. Was getting dark so i ran a jumper wire from the chassis batteries to the refrigerator for tonight.

Didnt pull out the house batteries to check the 250 amp house battery fuse but if the inverter turns on it has to be ok.

Anyone have an idea where to start. Thanks
neub is offline   Reply With Quote
Old 08-10-2022, 10:11 AM   #2
Winnebago Owner
 
Join Date: Sep 2017
Location: Apple Valley, MN
Posts: 128
Issue resolved

Issue resolved. It was a failed house battery isolation solenoid. I jumped it until i can get a replacement when i get home
neub is offline   Reply With Quote
Old 08-10-2022, 11:13 AM   #3
Winnebago Master
 
Join Date: Nov 2018
Location: Pflugerville/Austin, Tx
Posts: 4,987
Based on what I understand you have done, I might suggest care here as your jump to get power may mean you are using the last of your power which is coming from the start battery. That can mean you will not be able to start the engine!

With the jumper removed, are you able to start the RV engine? That is often the best plan when wondering about power as it does give a good source of good solid power from the alternator to all the other parts when things are working correctly.
__________________
Richard
Morich is offline   Reply With Quote
Old 08-10-2022, 12:44 PM   #4
Winnebago Owner
 
Join Date: Sep 2017
Location: Apple Valley, MN
Posts: 128
Thanks, yes with the jumper removed the rv does start. I just jumped the house battery disconnect solenoid which failed. The battery boast os still untouched so no power being used from the chassis for the house. All in one center os showing different voltages for the chassis and house.
__________________
2005 Winnebago Journey 36G, Cat C7
Apple Valley, MN
neub is offline   Reply With Quote
Reply

Tags
journey, power


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio Quit Working Suddenly Gattie Winnebago General Discussions 2 04-12-2022 12:20 PM
2017 minnie drop 170s A/C suddenly stopped taylorthedad Heating, Cooling and Appliances 1 05-26-2021 03:53 PM
Cigarette lighter and TV suddenly not working DebbyDiver Electrical | Charging, Solar and Electronics 11 04-13-2015 07:05 PM
Rear view camera suddenly stops working imported_Ron-in-TN Winnebago Class C Motorhomes 13 10-06-2012 02:57 PM
2007 V-10 Radiator suddenly overheating Fakrwee General Maintenance and Repair 5 05-09-2008 02:50 AM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 02:24 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
×