Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-30-2022, 07:03 AM   #1
Winnebago Camper
 
Join Date: Jul 2021
Posts: 14
Onan / Cummins EC-AGS+ on a QD 7500

Hello,
I hope I am posting this on the correct forum.


Two weeks ago I purchased a Cummins EC-AGS+. The unit was very easy to install. However, last week I purchased another because the first one didn't work properly. Unfortunately, the second one didn't work properly either.


I have spent a great deal of time and effort to try and get both of these units to work. It is nearly impossible to call Cummins and find someone who even knows what this product is and what it's functions are. Even the Level II tech people know very little about this product. It is VERY frustrating trying to solve the problems with them.


The first unit had no LED, it basically worked except that I was unable to program the temperatures I wanted the genset to start at. I simply could not enter the numbers, just single digits from 7-9. I did factory resets, deleted and reinstalled the app, nothing helped. I also had a great deal of trouble "authenticating" the gateway when trying to connect, app telling me no Bluetooth connection when there was. Repeatedly. I assume this was because the unit was not pulsing the LED and looking for a connection. Each time I tried to re-connect to the gateway, I would have to force stop the app and then re-open it to connect. PITA!



Cummins refunded my money and told me to order a new unit. This one had an LED and seemed to work, until I tried entering the startup temps again. Can only go from 5-9 this time. Tech claimed it was my phone fonts or "too much zoom" whatever that is supposed to be. However, the app screen for that setup is EXACTLY the same on my device as it is in the user manual pictures explaining setup.


Then the unit lost the temp sensor, took 20 minutes to re-establish while holding them side by side. App tells you to look for the MAC address but there's no way to manually enter it. This is unacceptable, who has the time to go through this stuff every time they want to turn on the programming?



Then the AGS auto setup menu in the app disappeared. Gone. Vamoosed. So I cannot set up battery voltage starts or AC/temp starts. And since I have deleted and re-installed the app umpteen zillion times, I threw in the towel and gave up.


I think the hardware is basically good. I can do all the manual things with the app (starting & stopping, flipping back and forth between manual and auto operation). It turns on in auto mode when battery is drained also. I think the problem is a really crappy app. Really, really crappy app.


And one last caveat, the gateway has NO monitoring for shore power connection, So, it CAN and WILL start the genset while connected to AC if it senses low battery voltage or reaches the programmed ambient temp in the coach. Assuming that it is actually possible to set the temperature


I would be interested in any problems, similar or otherwise that anyone has had with these units. The concept is good but the execution sucks big time IMO. I would appreciate hearing the experiences of anyone else who has experience with this product.
And it goes without saying that if you have overcome the built in flaws, I would love to hear about them as well.





Thanks, Darwin
medarwin is offline   Reply With Quote
Old 09-30-2022, 05:54 PM   #2
Site Team
 
creativepart's Avatar
 
Join Date: Sep 2009
Location: Spring Branch, TX
Posts: 6,226
Darwin, first I’m sorry you’re having problems. But I have to admit that I’ve never even heard of the Onan EC-AGS+ And had no idea it was available. Perhaps you should ask your question over on www.irv2.com - the winnieowners forum is an off shoot of that much larger RV forum. Since the Onan product isn’t specific to Winnebagos you are much more likely to find someone with experience with the EC-AGS+.

There’s nothing wrong about asking here, perhaps someone will come along with experience with this product. But, you are much more likely to get an answer over there.

Here’s a link to a thread on this topic from this past Summer on IRV2:

https://www.irv2.com/forums/f258/cum...ue-588991.html
__________________
2017 Winnebago Adventurer 37F
2016 Lincoln MKX Toad
creativepart is offline   Reply With Quote
Reply

Tags
cummins, onan


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AGS on Onan 10000 rv Qd Pilotguy Electrical | Charging, Solar and Electronics 1 04-30-2022 08:23 AM
Onan QD 7500 won't start bjboles Electrical | Charging, Solar and Electronics 3 08-22-2021 05:30 PM
Onan 7500 QD - Add a 30amp plug for trailer bjboles Electrical | Charging, Solar and Electronics 21 05-18-2021 09:23 AM
Performance comparison 350 Cummins to 425 Cummins buford Winnebago Class A Motorhomes 5 03-22-2021 11:37 AM
onan 7500 generator WIDGET33 Electrical | Charging, Solar and Electronics 8 10-05-2011 07:01 PM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 08:18 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
×