Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-10-2020, 07:19 PM   #1
Winnebago Camper
 
Join Date: Feb 2020
Posts: 22
Rad leak

Hi all. I have a weird problem with my 96 adventurer on a Ford chassis with a 460. When I fill the rad overflow tank to proper level I get a leak from somewhere on the rad that leaks onto rad cradle. It stops when the overflow goes down to the cold level. But when I remove the rad cap the rad is full and no more leak. Its not coming from the overflow tank.
Anyone had this issue?
Thanks
Rhyno is offline   Reply With Quote
Reply

Tags
leak


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slide leak & post leak (I hope) pictures John_Canfield General Maintenance and Repair 6 12-07-2005 10:23 AM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 12:58 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×