Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-17-2009, 08:34 PM   #1
Winnebago Owner
 
Join Date: Oct 2006
Posts: 52
Norcold Frig. - Problem -- Board

2003 Ultimate Freedom with Norcold frig. -- 4 door with icemaker -- got recall letter -- unit at rv dealer now -- can't keep new board working for more than 24 hrs. -- all goes blank on monitor panel -- you can hear it click -- worked fine until recall finished -- any ideas??? need to leave for florida on 12/22/09 -- up against the clock !!!! -- at least 3rd. board now!! --UGH !!!
__________________
Bill
FenceMan is offline   Reply With Quote
Old 12-17-2009, 09:25 PM   #2
Winnebago Master
 
MrTransistor's Avatar
 
Join Date: Jan 2004
Location: Albuquerque, NM
Posts: 504
Several questions;

What specific model of Norcold do you have?

Do you know what the recall entailed and do you have the recall number?

Was the board replaced with the recall and could the original board be reinstalled?

This community will do itís best to help.
__________________
Have Fun!! Mark & Donalda 04 Horizon 40WD no TOW 90,900+ miles and counting
Triumph Bonneville & Susuki S40 on the back
MrTransistor is offline   Reply With Quote
Old 12-17-2009, 09:39 PM   #3
Winnebago Master
 
"007"'s Avatar
 
Join Date: Oct 2004
Posts: 629
Maybe you have a defective heat thermistor on your recall installation collar, its on that shiney metal one at base of your burner flue. Place a jumper across the two red leads to bypass it. It may have cut off your 12v to your circuit board.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 12-17-2009, 10:04 PM   #4
Winnebago Owner
 
Join Date: Oct 2006
Posts: 52
thanks -- i forwarded to rv dealer -- have him check it in the morning!
__________________
Bill
FenceMan is offline   Reply With Quote
Old 12-18-2009, 11:29 PM   #5
Winnebago Owner
 
Join Date: Oct 2006
Posts: 52
dealership replaced part on stack -- did load test on house batteries -- they showed 12.6 v. but failed the load test --- frig. has been running all day -- just checked it a few min. ago -- still going --- thanks for the advice!!

bill
__________________
Bill
FenceMan is offline   Reply With Quote
Old 12-18-2009, 11:43 PM   #6
Winnebago Master
 
"007"'s Avatar
 
Join Date: Oct 2004
Posts: 629
Thanks for the followup, have a safe one enjoy your RV.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 12-19-2009, 02:31 PM   #7
Winnebago Owner
 
Join Date: Oct 2006
Posts: 52
spoke too soon -- out again --- dealer said to unplug 110v and 12 volt to the board and wait two hours and plug back in -- did not do the jumper wire thing yet -- sad thing is -- unit worked fine until "recall" was done
__________________
Bill
FenceMan is offline   Reply With Quote
Old 12-19-2009, 11:12 PM   #8
Winnebago Owner
 
Join Date: Oct 2006
Posts: 52
unit is a norcold mod. 1201LRIM -- 4 door with ice maker -- LP/110V/or inverter
__________________
Bill
FenceMan is offline   Reply With Quote
Old 12-20-2009, 01:11 AM   #9
Winnebago Master
 
MrTransistor's Avatar
 
Join Date: Jan 2004
Location: Albuquerque, NM
Posts: 504
Hi Bill,

I just read the recall info for the 1201LRIM and it looks like the only thing involved was the addition of a thermal switch. As far as you know, was any other work involved in your recall?

If the original board was not replaced, and the only thing involved was the thermal switch, then either the switch was connected incorrectly, is defective, or the switch is doing its job and shutting the unit down. If that is the case, then you have some defect causing the overheat condition and that needs to be addressed!

Either way, seems like Norcold needs to instruct the repair center to verify the connections and measure the temperatures to determine which it is and get it corrected, either by replacing the evaporator unit or adjusting the gas flow to bring it into specs. Keep us posted.
__________________
Have Fun!! Mark & Donalda 04 Horizon 40WD no TOW 90,900+ miles and counting
Triumph Bonneville & Susuki S40 on the back
MrTransistor is offline   Reply With Quote
Old 12-21-2009, 10:33 AM   #10
Winnebago Master
 
AFChap's Avatar
 
Join Date: Aug 2002
Location: ...hopefully on the road!
Posts: 1,558
The recall kit does not include any boards ...they use the originals. It is possible that the board could have gone bad at just the wrong time, but the more likely problem is something else they did, bad thermal switch, etc. What I don't know is whether or not the thermal switch they install is a trip-once replace, or can it be tripped and reset somehow for another use???
__________________
Paul (KE5LXU) ...was fulltimin', now parttimin'
'03 Winnebago UA 40e / '05 Honda Odyssey toad
AFChap is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:35 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.