Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-22-2017, 08:58 PM   #1
Winnebago Owner
 
Pushrod's Avatar
 
Join Date: Apr 2006
Location: Camano Island, Washington
Posts: 63
Subwoofer power

So, after a year and a half, I discovered my subwoofer isn't working. This is in my 2015 40R, Meridian. The connectors to the unit were faulty, poorly crimped, so after a big hassle, and replacing the connections, I finally discovered there was no voltage. Looking at the schematic, it must be 12 volt, so after checking all the breakers, none were tripped. The schematic does not show where the voltage source is, or if it is breaker protected, any ideas where to check next? The subwoofer is located under the couch in the kitchen side slide.
__________________
"Time is Nature's way of not letting everything happen at once."
2015 Itasca Meridian 40R
2010 Escape
Pushrod is offline   Reply With Quote
Old 01-22-2017, 09:19 PM   #2
Winnebago Master
 
Ray,IN's Avatar
 
Join Date: Aug 2001
Location: North America somewhere
Posts: 695
My reply is to subscribe, as mine is in the same place and doesn't work either. I hope someone knows. I've looked everywhere I can see, to no avail.
__________________
2000 Winnebago Ultimate Freedom USQ40JD, ISC 8.3 Cummins 350, Spartan MM Chassis. USA 1SG, retired;PPA,Good Sam Life member,FMCA."We the people are the rightful masters of both the Congress and the Courts - not to overthrow the Constitution but to overthrow men who pervert the Constitution. "Abraham Lincoln"
Ray,IN is offline   Reply With Quote
Old 01-22-2017, 10:29 PM   #3
Winnebago Camper
 
Join Date: Nov 2015
Location: South Carolina
Posts: 30
On mine it does work but not very good sound. It is not a powered subwoofer, so no voltage to it. You have to turn the volume up and down with the sound bar remote subwoofer buttons. Mine was turned all the way down. When I turn it up it works, but if I go to high it starts thumping.
__________________
George & Karen with 2 Border Collies (Brite & Mitch)
2015 Winnebago Journey 40R
2015 Ford C-Max
aiken rver is offline   Reply With Quote
Old 01-23-2017, 11:50 AM   #4
Winnebago Owner
 
Pushrod's Avatar
 
Join Date: Apr 2006
Location: Camano Island, Washington
Posts: 63
Mine is an LG2540. I pulled out, and to my surprise, it's NOT a Bluetooth, it is supposed to be hard wired, and it has never been connected. Now the question is, how to find the wires that are connected to the SW, and get them to the sound bar.
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	55
Size:	279.1 KB
ID:	149856  
__________________
"Time is Nature's way of not letting everything happen at once."
2015 Itasca Meridian 40R
2010 Escape
Pushrod is offline   Reply With Quote
Old 01-24-2017, 07:41 AM   #5
Winnebago Camper
 
Join Date: Nov 2015
Location: South Carolina
Posts: 30
First, check your sound bar to see if the wiring cable is attached at that end. If not you will need to run a cable somehow. If the cable is there it should come up through the floor under the rear corner of your sofa, which is where the subwoofer is located (at least on mine).
__________________
George & Karen with 2 Border Collies (Brite & Mitch)
2015 Winnebago Journey 40R
2015 Ford C-Max
aiken rver is offline   Reply With Quote
Old 01-24-2017, 10:40 AM   #6
Winnebago Owner
 
Pushrod's Avatar
 
Join Date: Apr 2006
Location: Camano Island, Washington
Posts: 63
As you can see, the sound bar is not connected. The sub woofer is, but the wiring never made it to the other side of the coach. Just checked the wiring coming up under the cabinet behind the tv, had to pull the base flooring up, no sub woofer wiring to be found. I'm hoping Mother Winnebago will stand up to taking care of this even though I'm out of warranty.
__________________
"Time is Nature's way of not letting everything happen at once."
2015 Itasca Meridian 40R
2010 Escape
Pushrod is offline   Reply With Quote
Old 01-24-2017, 12:29 PM   #7
Winnebago Master
 
Jim_HiTek's Avatar
 
Join Date: Nov 2011
Location: Full time RV'er
Posts: 787
According to the 2540 Spec Sheet, the subwoofer IS suppose to be wired. The main sound bar is Bluetooth though.

I wonder if Winnie had planned on putting in a RF or IR transmitter/receiver for the subwoofer in some units? Not likely, but, you never know.

Meanwhile, sounds like you'll have to hardwire it somehow.

Please keep us posted on what you come up with...
__________________
'02 Winnebago Journey DL, DSDP, 36' of fun.

Visit my RV Travel & Repair Blog at : http://chaos.goblinbox.com
Jim_HiTek is offline   Reply With Quote
Old 01-24-2017, 02:44 PM   #8
Winnebago Owner
 
Pushrod's Avatar
 
Join Date: Apr 2006
Location: Camano Island, Washington
Posts: 63
Solved!

After help from Tommy and Brian at Mother Winnebago, traced wiring into wife's closet, found sub woofer wires dead ended on floor under tv cabinet. Snaked two extension wires through wall and into cabinet behind tv, hooked up to sound bar, we now have BASS! Turn it up!
__________________
"Time is Nature's way of not letting everything happen at once."
2015 Itasca Meridian 40R
2010 Escape
Pushrod is offline   Reply With Quote
Reply

Tags
power


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no power unless hooked to shore power ken551 Electrical | Charging, Solar and Electronics 7 06-21-2012 06:55 PM
No power in house when off shore power. Batteries good. wbezemek Electrical | Charging, Solar and Electronics 13 01-04-2012 08:16 PM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:49 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×