Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-12-2019, 08:04 PM   #1
Winnebago Watcher
 
Join Date: Dec 2017
Posts: 4
xantrex Pro 1000 problem

2016 Winnie 30T Vista...The invertor in my MH does not appear to be working. The gage mounted on the interior wall does not light up and does not work. It has two buttons one marked select and one green with a symbol on it. I did not receive any manual for how this operates but it does not light up and shows 8.8.8 at all times. I have pulled the shield that is over the invertor and at the point I am done. I cannot find any fuses that go to it and there seems to be no reset button like my DP had on its 2500 unit...Any suggestions are greatly appreciated, I would like to get this unit working...Invertor is the 1000.
Jeeper is offline   Reply With Quote
Old 02-13-2019, 01:01 AM   #2
Let's kill some bugs!
 
Join Date: Oct 2018
Location: Yorba Linda, CA
Posts: 141
Send a message via Skype™ to John Locke
Quote:
Originally Posted by Jeeper View Post
2016 Winnie 30T Vista...The invertor in my MH does not appear to be working. The gage mounted on the interior wall does not light up and does not work. It has two buttons one marked select and one green with a symbol on it. I did not receive any manual for how this operates but it does not light up and shows 8.8.8 at all times. I have pulled the shield that is over the invertor and at the point I am done. I cannot find any fuses that go to it and there seems to be no reset button like my DP had on its 2500 unit...Any suggestions are greatly appreciated, I would like to get this unit working...Invertor is the 1000.
Suggest you visit the Xantrex website and download the user guide. If it's the Freedom model, here's the guide.

Otherwise you can go here to select your model. If you don't see a photo of your inverter, call Xantrex in Canada, they're nice folks.

First I recommend to check if the inverter is getting 12V to the input side. Check that with a VOM. If there is no 12V getting to the inverter, there's usually a 100 or 150A fuse on the 2GA power wire to the inverter from the house battery. I suggest finding that fuse, and check it for continuity.
__________________
2018 Vista 32YE
Phantom 4P, RZR900, Haibike Xduro 6.0
S&W Shield
John Locke is online now   Reply With Quote
Reply

Tags
xantrex


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2019 Vista 29VE outlets the 1000 watt inverter energizes? Noah4448 Electrical | Charging, Solar and Electronics 4 10-09-2018 06:35 AM
Xantrex inverter problem Dennis L Welcome Mat 2 06-24-2018 02:27 PM
How to wire up a Xantrex XM1000 Pro Series Inverter? Navion 24J Electrical | Charging, Solar and Electronics 6 06-03-2015 09:04 AM
Xantrex XM 1000 inverter issue on Vista 32k Eggz2 Winnebago Class A Motorhomes 9 11-05-2014 09:52 AM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:24 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.