Closed Thread
 
Thread Tools Search this Thread Display Modes
 
Old 04-28-2009, 06:49 PM   #1
Winnebago Master
 
Wayne M's Avatar
 
Join Date: Aug 2008
Location: Texas
Posts: 914
PT50C - Any ideas

A problem was my electrical hook up. I am (was) using a PT50C protector. I hooked it to the pedestal and went inside the coach. My wife complained that the electrical plugs were not working. Back outside, check the PT50C
and it inidacted all was normal on the readout. Started checking circuit breakers inside the coach, etc., I was getting wet from the internal body temperature sensor. After a long time, my wife said, "Did you see if it worked without that gadget?" And my reply was, "No, there is nothing wrong with that gadget. Everything reads normal, but just to satisfy you I will!" Of course, I was testy by this time, so I'm told. I removed the PT50C and plugged the umbilical directly into the 50 amp power. Poof! Magic! (not poof like in smoke) The 120v receptacles all worked. I said to my wife, "I hate to say this, I really do, but (choke) you were right." I think I saw a subtle smile. It wasn't so subtle when she reminded me as I was talking to Progressive Industries technician.

Anyhow, troubleshooting with the technician from Progressive Industries, via phone, was non-productive. .Everything appears normal, but with the PT50C plugged in, there is no voltage to the 120v appliance recepticals. Progressive Industries is baffled, as well as I am. Of course it doesn't take much to baffle me. They are sending me another PT50C with an RMA for the old one. I am supposed to have it by Friday

We'll see!

The PT50C was reading E-0, Line 1 - 119v 0A, Line 2 120v 22A (AC running)

Help??????
__________________
Wayne MSGT USMC (Ret) & Earlene (CinCHouse)
2015 Winnebago Tour 42QD 2008 Winnebago Destination 39W
(RVM-14) It is what it is, and then it is what you make of it.
Wayne M is offline  
Old 05-01-2009, 08:09 AM   #2
I helped | retired moderator
 
Route 66's Avatar
 
Join Date: May 2000
Location: Newark, DE
Posts: 285
Duplicate post.

Other post here.
__________________
Adios, Dirk - '84 Real Lite Truck Camper, '86 Wilderness Cimarron TT, previously 4 years as a fulltimer in a '07 DSDP

Route 66 is offline  
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Progressive Ind EMS-PT50C-? Anyone use w/AGS Surge Gd #41260? BeHappy Electrical | Charging, Solar and Electronics 15 05-31-2015 06:54 AM
First trip with new coach and refer kept blowing out...any ideas? Stevegd007 Campgrounds, Travel and Attractions 18 08-27-2007 03:57 PM
Stuck A&E Topper Awning, Any ideas? Alfred622 General Maintenance and Repair 6 08-01-2006 04:14 AM
We need more satellite cable wiring - Any ideas Scooter Electrical | Charging, Solar and Electronics 12 02-09-2005 01:42 AM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:24 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.