Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-06-2010, 09:05 PM   #1
Winnebago Watcher
 
Join Date: Dec 2009
Location: Mt. Gilead, Ohio
Posts: 2
Onan shuts down

Onan 7500 watt Diesel shuts down under load after about 5 min. Codes say high coolant temp shut down ?????. Coolant and oil OK, air inlet and outlet OK. Gen. has 140 hr. Drained coolant, flushed and refilled no help. Can't get into shop before the 15th any ideas?

thanks
Dave
Multiengine is offline   Reply With Quote
Old 07-07-2010, 04:32 AM   #2
Winnebago Camper
 
Join Date: Jul 2005
Posts: 42
Dave, just a thought but the Onan has a water pump belt that may have seen its useful life and be loose or broken. The problem with our coaches that an easy repair is made almost impossible because you have to lower the Onan out the bottom of a raised coach to remove the top cover. The Onan weighs just about 500 lbs so it is not something most owners would attempt.
__________________
Itasca Meridian 36G 2007
2011 Cadillac SRX AWD or
2002 Saturn SL2
KennethM is offline   Reply With Quote
Old 07-07-2010, 08:49 AM   #3
Winnebago Camper
 
squeak's Avatar
 
Join Date: May 2009
Location: Parker Az
Posts: 6
Dave before you do anything check underneath the gen. you will see the radator and make sure that it is clear. mind had leaves paper grass hosed it off now it is fine. I have changed my belt on my onan when it was in my MH lot of work.
squeak is offline   Reply With Quote
Old 07-07-2010, 12:48 PM   #4
Winnebago Master
 
AFChap's Avatar
 
Join Date: Aug 2002
Location: ...hopefully on the road!
Posts: 1,588
I had shut down due to "coolant temp" code after I had the coolant changed. After one shutdown I heard the coolant gurgling. I had to pull the coolant fill tube out of the enclosure and run it awhile w/o the cap to "burp" all the air out. If there is an air pocket, the genny will shut down with a hi temp error even though the coolant itself is not hot.
__________________
Paul (KE5LXU) ...was fulltimin', now parttimin'
'03 Winnebago UA 40e / '05 Honda Odyssey toad
AFChap is offline   Reply With Quote
Old 07-07-2010, 11:06 PM   #5
Winnebago Camper
 
squeak's Avatar
 
Join Date: May 2009
Location: Parker Az
Posts: 6
ok all is fine?
squeak is offline   Reply With Quote
Old 07-07-2010, 11:28 PM   #6
Winnebago Camper
 
RVDude's Avatar
 
Join Date: Sep 2006
Posts: 25
AFCHap has it, burp that radiator cap!

After changing the coolant it takes a while to get it to completely fill all the internal areas. Running it open and then capping it for a while and then just cracking the cap when slightly warm will all help get the air out.
__________________
2007 and 7/8ths Newmar Essex 4502
RVDude is offline   Reply With Quote
Old 08-18-2010, 07:30 AM   #7
Winnebago Watcher
 
Join Date: Dec 2009
Location: Mt. Gilead, Ohio
Posts: 2
After 3 weeks in the shop they found the problem Coolant Senson was broke.

Dave
Multiengine is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan Genset Shuts Off When On Road With Outside Temperature 90 Degrees Plus LR Campgrounds, Travel and Attractions 11 07-15-2016 01:44 PM
Gas Onan 5500 shuts down after start antec7 Winnebago General Discussions 10 07-04-2006 04:28 AM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:03 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×