Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-10-2018, 09:43 AM   #1
Winnebago Watcher
 
Join Date: Apr 2014
Posts: 4
Lights Flicker When Water Pump Runs

So I'm sitting here in our 2016 Itasca Meridan 38P while my wife is showering and I'm being treated to a light show. The LED lights throughout the main living area flash randomly when the water pump starts up and less so when it shuts down. Big time. Being low voltage devices I am assuming that a current from the motor is inducing current in the associated power lines for the lights.

We had seen this to a much smaller degree in the bedroom when running the ceiling fan.

Both devices, I assume, are drawing relatively high currents, hence my induction deduction (see what I did there?).

Is this something to worry about?

Jp
wanna-travel is offline   Reply With Quote
Old 03-10-2018, 10:58 AM   #2
Winnebago Owner
 
Lv2Roam2's Avatar
 
Join Date: Jun 2014
Location: Somewhere On the Road
Posts: 200
This is a known issue with WBGO - fixes have included replacement pumps, electrical system diodes and better grounding. Recommend you search the IRV2 posts - there are a number of dialogues about the issue.

Should also call WBGO and see if they can recommend a DIY fix. Not sure all the dealers are conversant on this topic so taking is in for service could get expensive very quickly.

Let us know what you learn / do ... we all benefit ... thanks
__________________
Steve
2015 Itasca Ellipse QD | 2014 Jeep Grand Cherokee
Lv2Roam2 is offline   Reply With Quote
Reply

Tags
light, lights, water, water pump


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 Sughtseer 33c chassis battery runs down Laker44 Electrical | Charging, Solar and Electronics 6 11-26-2014 04:21 PM
furnace operation when propane runs out Jim General Maintenance and Repair 12 12-27-2012 01:00 PM
generator starts n runs but dies after 3-4 min 94bago Electrical | Charging, Solar and Electronics 12 07-10-2012 01:17 PM
Norcold Refer fan runs forever Frank & Marilyn Heating, Cooling and Appliances 6 06-29-2012 09:45 AM
Fridge only runs on LP ? Hawkeye Heating, Cooling and Appliances 10 09-02-2011 07:34 PM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:12 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×