Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-16-2019, 08:27 PM   #1
Winnebago Camper
 
Join Date: Mar 2019
Posts: 7
GFI tripping

My 2012 Itasca Ellipse trips any 20 amp GFI receptacle. I have no problems when it is plugged into a non-GFI 20 amp receptacle, 30 amp receptacle, or 50 amp receptacle. I have replaced both the house and chassis batteries and the problem remains. Can anyone share troubleshooting ideas with me.
audvm1984 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Itasca Solei GFI Not Working stevegster Winnebago Class A Motorhomes 7 02-17-2016 03:49 PM
15 amp GFI Shore power for storage DNLRV Electrical | Charging, Solar and Electronics 20 01-14-2016 07:19 PM
GFI outlet 2013 Sunstar 27N jjk0091 Winnebago Class A Motorhomes 7 09-16-2015 12:36 AM
Tripping Breakers stardalo Electrical | Charging, Solar and Electronics 14 12-11-2010 10:35 PM
Heart Freedom 20 pops house GFI craigt Electrical | Charging, Solar and Electronics 9 12-13-2007 06:33 AM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:47 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×