Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-15-2009, 05:03 PM   #1
Winnebago Owner
 
Magumba's Avatar
 
Join Date: Oct 2009
Location: On the Road
Posts: 74
Family radios not charging?

Hi,
We've owned our 03 Suncruiser for a few months now. I noticed recently that the family radios are all dead. I changed the batteries of on of the radios and installed new rechargable batteries in October.
None of the 12 V circuit brakers are popped.
Any ideas? Thanks for your ideas.
Magumba is offline   Reply With Quote
Old 11-15-2009, 05:08 PM   #2
Winnebago Owner
 
Join Date: May 2007
Location: Indiana
Posts: 64
Try cleaning the electrical connections for the batteries in the radios and the charger with a pencil eraser. They sometimes get corrosion on them that isn't noticeable without a close look.
Good Luck, Indiana Journey
indiana journey is offline   Reply With Quote
Old 11-15-2009, 08:15 PM   #3
Winnie-Wise
 
Join Date: Jul 2006
Location: Michigan
Posts: 312
Are you referring to the built-in charger station and radios?

If so, do you get the red or green (charging or charged) lights when you insert a radio?

If not, probably no power. Unscrew the four screws in the bezel and remove the charger unit and check for an inline fuse in the 12v wire.

I had to replace it on mine when it stopped charging.
__________________
Ed & Joie
2004 Vectra 40KD
Freightliner Chassis and Cummins ISC
emiddleb is offline   Reply With Quote
Old 11-16-2009, 05:02 AM   #4
Winnie-Wise
 
Thudman's Avatar
 
Join Date: Sep 2003
Location: Destin, FL
Posts: 494
I went thru two charger stations before mine worked properly. That was about six years ago, and the four radios have worked fine ever since. I use them all the time in my job.

Thudman
__________________
03 Adventurer 38G, W22, 22.5 Whls

Koni FSD's, TracBar rear, SteerSafe, 50A SurgeGuard, Eternabond; 2012 Honda CRV EXL w/Nav & AWD
Thudman is offline   Reply With Quote
Old 11-16-2009, 08:00 PM   #5
Winnebago Owner
 
Magumba's Avatar
 
Join Date: Oct 2009
Location: On the Road
Posts: 74
Yes I'm refering to the built in radios. Inline fuse, tricky I never thought of that. No I don't remember seeing a charge lights. I tried to check the charge voltage and the meter read zero, I thought there might be a switch built in the door and the circuit was open when door was open.
I'll check it out tomorrow when I'm off.
Thanks for your help.
Magumba is offline   Reply With Quote
Old 11-18-2009, 06:19 PM   #6
Winnebago Owner
 
Magumba's Avatar
 
Join Date: Oct 2009
Location: On the Road
Posts: 74
Good suggestion to check the fuse.

Guys,
Well I pulled the charger unit out last night. The fuse holder was broken and the fuse was AWOL. So I replace the fuse holder and fuse and now the unit charges the radios.
Thanks for the help. Camp safely.
Magumba is offline   Reply With Quote
Old 11-20-2009, 05:13 PM   #7
Winnebago Camper
 
Join Date: Apr 2008
Location: Wilds of West Kentucky
Posts: 46
Had a Suncruiser with this equipment for two years and the little radios never charged.
__________________
2009 Winnebago Tour 40TD
Pulling a Ford Escape Hybrid with Blue Ox stuff
Rockhouse is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CB Radios AlwaysDusty Electrical | Charging, Solar and Electronics 19 08-19-2013 07:25 AM
Looking for 2 Audiovox GMRS100 radios CWHTRAINS Tech | Toys and Gear 8 05-08-2009 09:35 AM
TV Inverter, and Two Way Radios Al Spivey Electrical | Charging, Solar and Electronics 7 08-11-2008 04:36 PM
Audiovox FRS Radios NR4A Electrical | Charging, Solar and Electronics 11 09-23-2006 05:16 PM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:59 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×