Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-24-2010, 02:35 PM   #1
Winnebago Watcher
 
Join Date: Jan 2010
Posts: 2
2006 Journey Dead Chassis Battery and Trick-L-Charger

We have a 2006 Winnebago Journey and a problem with our engine batteries going dead. From what I have read about this, our 06 journey should have a Trick-L-Charger already installed but I don't think it does. We looked in the compartment behind the hood where we were told it should be and did not see it. Is it possilbe that it is somewhere else? Any suggestions on the battery problem.

Kathy S
jrny06owner is offline   Reply With Quote
Old 01-24-2010, 03:07 PM   #2
Winnebago Master
 
AFChap's Avatar
 
Join Date: Aug 2002
Location: ...hopefully on the road!
Posts: 1,585
Call Winnebago Owner Relations at 800-537-1885 and give them your coach s/n. They can tell you for SURE whether or not your coach had the trik-l-start installed when built, and if so, where it would be located.
__________________
Paul (KE5LXU) ...was fulltimin', now parttimin'
'03 Winnebago UA 40e / '05 Honda Odyssey toad
AFChap is offline   Reply With Quote
Old 01-24-2010, 05:48 PM   #3
Winnebago Master
 
MrTransistor's Avatar
 
Join Date: Jan 2004
Location: Albuquerque, NM
Posts: 504
Hi Kathy,

For your coach, Adobe Page 71 of this drawing shows an Ultra Trik-L-Start installed just beside the two contactors for Aux Start and Battery Disconect.

http://www.winnebagoind.com/diagram/...0167475040.pdf
__________________
Have Fun!! Mark & Donalda 04 Horizon 40WD no TOW 90,900+ miles and counting
Triumph Bonneville & Susuki S40 on the back
MrTransistor is offline   Reply With Quote
Old 01-24-2010, 06:21 PM   #4
Winnebago Master
 
Pusherman's Avatar
 
Join Date: Oct 2006
Location: Rochester NY
Posts: 813
I believe Winnebago phased in the Trik-L-Start in model year 2005 or 2006 during the middle of the production year. If this is the case, you may have an earlier production coach w/o this product.

If it's working, an easy way to determine if it's installed and operating is to check the engine battery voltage from the one-place panel when it's plugged into ac. You will note a 13+V on the house batteries when plugged in, and it should be similar on the engine batteries as well.

If the engine battery voltage only reads mid-12V or less, then it is either not working or not installed on this coach.

Hope this helps.
__________________
Don
'07 Winnebago Journey 34H - CAT C7, Koni's, MCU's, SS Bell Crank, Safe-T-Plus
'07 HHR Toad, SMI AFO, Blue OX
[SIGPIC][/SIGPIC]
Pusherman is offline   Reply With Quote
Old 01-24-2010, 06:47 PM   #5
Winnebago Camper
 
Join Date: May 2007
Location: Texas
Posts: 21
My '06 Journey with build date of 7-6-05 did not have a factory installed Trik l Charger. I added it.
__________________
'06 W Journey,36G,'07 Yukon,Rdmstr, M & G Brake,Alpine Nav, KVH R6, Direct TV, PortaBote Under,
Bill Barclay is offline   Reply With Quote
Old 01-24-2010, 08:55 PM   #6
Winnebago Owner
 
Join Date: Mar 2002
Location: Western WA
Posts: 209
Our '07 34H was built in Oct/Nov of 2006 and it did have the Trik-L-Start installed as original equipment. By spec, it will maintain the chassis batteries .3 volt less than the house batteries. I replaced my battery boiling Parallax 7455T converter/charger with a PD 9260 with the Wizard. On all three rates of charge, my chassis battery voltage reads .3 volts less than the house batteries using the gauge on the electrical panel.
__________________
'07 Winnebago Journey 34H, ISB-02, MH2500
Toad - '08 Ford Taurus X
Blue Ox, Aventa
US Gear UBS
FleetMan is offline   Reply With Quote
Old 01-25-2010, 09:48 AM   #7
Winnebago Watcher
 
Join Date: Jan 2010
Posts: 2
Thanks for all the good info. Our plan of action is to get some new batteries as the level shows 9.3, so I am assuming they are shot, and install the trick-l-charge. Hopefully that will do the trick.

kathy S
jrny06owner is offline   Reply With Quote
Old 01-25-2010, 10:41 PM   #8
Winnebago Master
 
SCVJeff's Avatar
 
Join Date: Dec 2006
Location: Santa Clarita, CA.
Posts: 1,217
I don't know where to find the build date, somehow I think is was mid 2006, but ours DOES have it installed. It's behind the front CB access door and is pretty hard to miss.
__________________
_______________________________

Jeff - WA6EQU
'06 Itasca Meridian 34H, CAT C7/350
SCVJeff is offline   Reply With Quote
Old 01-26-2010, 02:38 PM   #9
Winnebago Master
 
AFChap's Avatar
 
Join Date: Aug 2002
Location: ...hopefully on the road!
Posts: 1,585
Your build date is on the data label on the wall near the driver seat ... look in the upper left at the Built by Winnebago emblem. There should be a date directly under the emblem. For example, mine says "05/02"
__________________
Paul (KE5LXU) ...was fulltimin', now parttimin'
'03 Winnebago UA 40e / '05 Honda Odyssey toad
AFChap is offline   Reply With Quote
Old 01-26-2010, 07:00 PM   #10
Winnebago Master
 
SCVJeff's Avatar
 
Join Date: Dec 2006
Location: Santa Clarita, CA.
Posts: 1,217
OK, that's what I thought but was thinking it was a Freightliner incomplete date.

Under the Winne plaque, it's 9-05
__________________
_______________________________

Jeff - WA6EQU
'06 Itasca Meridian 34H, CAT C7/350
SCVJeff is offline   Reply With Quote
Old 01-26-2010, 07:48 PM   #11
Winnebago Master
 
AFChap's Avatar
 
Join Date: Aug 2002
Location: ...hopefully on the road!
Posts: 1,585
Quote:
was thinking it was a Freightliner incomplete date
The chassis date would be on Freightliner paperwork. Mine has a Spartan chassis. I also have a couple of Spartan certificates in my owner briefcase that have an "incomplete vehicle mfr date" of APR 2002
__________________
Paul (KE5LXU) ...was fulltimin', now parttimin'
'03 Winnebago UA 40e / '05 Honda Odyssey toad
AFChap is offline   Reply With Quote
Old 01-26-2010, 07:54 PM   #12
Winnebago Master
 
SCVJeff's Avatar
 
Join Date: Dec 2006
Location: Santa Clarita, CA.
Posts: 1,217
It's on there too now that I know what I'm looking for. Chassis: 7-05
__________________
_______________________________

Jeff - WA6EQU
'06 Itasca Meridian 34H, CAT C7/350
SCVJeff is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trick L Start on 08 Voyage Finhawk Winnebago Class A Motorhomes 9 07-15-2008 10:30 AM
chassis battery dead FireStarter Electrical | Charging, Solar and Electronics 6 02-05-2007 04:57 PM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:59 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×