Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-04-2018, 01:34 AM   #1
Winnebago Camper
 
Join Date: Nov 2016
Posts: 6
1985 Itasca windcruiser

I recently installed a suburban IW60 tankless hot water heater. Everything works fine when the water heater is off. When I turn it on the voltage goes up yesterday 15v today 18v when I turn the heater off the volts go back to 12v. Last week I noticed if I left the heater on the display would start to flash. Now if I leave it on the #2 fuse blows.
Rvjoe1 is offline   Reply With Quote
Reply

Tags
itasca


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan starter sol.wiring diagram Onan 6.5 rv 1985 Rede2go Electrical | Charging, Solar and Electronics 1 12-11-2017 08:03 AM
1985 minnie winnie rims and tires colantuono Running Gear, Axles, Brakes, Wheels and Tires 11 09-21-2012 04:17 PM
1985 phasar johnlewis51 Vintage Rigs - Retro is cool! 11 09-05-2011 10:49 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:45 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.