Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-03-2013, 09:54 AM   #1
TAN
Winnebago Owner
 
Join Date: Jun 2007
Location: Coaldale, AB
Posts: 64
Jacks not working

When I push the button to make the jacks go down the front start going down and when I remove my finger from the button they don't stop, I have to hit the off button. The right one's work the same way. The back ones don't work and the left side don't work. I am at a loss, I don't know what to look at. Please help.
__________________
05 Itasca Sunova 29R
TAN is offline   Reply With Quote
Old 05-03-2013, 10:22 AM   #2
Winnie-Wise
 
BFlinn181's Avatar
 
Join Date: Jan 2012
Location: Cincinnati
Posts: 486
You didn't mention what brand you have. When I encountered problems with my Quadra Bigfoot system I contacted the company and talked to a tech that walked me through so tests. He then determined my control panel needed help. I shipped the panel to them, they repaired it and sent me a new limiting switch for one of the jacks that also might have been bad. NO CHARGE! I was quite pleased.
__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is offline   Reply With Quote
Old 05-03-2013, 10:36 AM   #3
TAN
Winnebago Owner
 
Join Date: Jun 2007
Location: Coaldale, AB
Posts: 64
They are called Level Best buy Kwikee Products.
__________________
05 Itasca Sunova 29R
TAN is offline   Reply With Quote
Old 05-03-2013, 10:56 AM   #4
Winnie-Wise
 
BFlinn181's Avatar
 
Join Date: Jan 2012
Location: Cincinnati
Posts: 486
Here's links to tech and operational manuals. I see your jacks have an automatic mode. I wonder if you were in auto mode and that's why they started and kept going?

http://support.powergearus.com/techdocs/1422192.pdf

Technical Documents - Power Gear
__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is offline   Reply With Quote
Old 05-03-2013, 11:06 AM   #5
TAN
Winnebago Owner
 
Join Date: Jun 2007
Location: Coaldale, AB
Posts: 64
They are manual jacks. Not automatic.
__________________
05 Itasca Sunova 29R
TAN is offline   Reply With Quote
Old 05-03-2013, 11:58 AM   #6
Winnebago Camper
 
fun 33V's Avatar
 
Join Date: Oct 2010
Posts: 36
level best

Is your engine running for max voltage? If so I would try rebooting the panel remove the two connecters on the rear side for a couple of mins & try again good luck.
__________________
2005 Itasca 33V Sunrise 8.1 Workhorse W-20
fun 33V is offline   Reply With Quote
Old 05-03-2013, 12:51 PM   #7
Winnie-Wise
 
Kazoo Tom's Avatar
 
Join Date: Feb 2006
Location: Kalamazoo, Michigan
Posts: 367
If you go to the power gear site referenced above, you can put in your year, make, model, and chassis information and it will bring up the documents for your specific system.
__________________
Tom and Barb
'07 Winnebago Voyage 35L
Workhorse W22 chassis FMCA 219315
Kazoo Tom is offline   Reply With Quote
Old 05-03-2013, 04:57 PM   #8
Winnebago Camper
 
Join Date: May 2011
Location: Central, South Carolina
Posts: 12
I had problems with my double acting Kwickees of a slightly different nature. I pulled the fuse for the system and opened up the control box. In it were several ribbon connectors without interlocks. One was partially extracted from vibrations. I fully reinserted it into the socket, placed a dab of RTV on it to hold it from now on, and the trouble was gone.
Who knows what can happen if one of those connectors comes loose. I think you should check it out before doing an analysis.
__________________
garyspang is offline   Reply With Quote
Old 05-03-2013, 11:42 PM   #9
TAN
Winnebago Owner
 
Join Date: Jun 2007
Location: Coaldale, AB
Posts: 64
I have owned this MH since new but I do not no where the control box is. Thanks
__________________
05 Itasca Sunova 29R
TAN is offline   Reply With Quote
Old 05-04-2013, 05:45 AM   #10
Winnebago Camper
 
Join Date: May 2011
Location: Central, South Carolina
Posts: 12
The control box is the same box that has the membrane switches that you push for turning the jacks off and on, and making all four jacks go up and down.
__________________
garyspang is offline   Reply With Quote
Old 05-04-2013, 07:11 AM   #11
TAN
Winnebago Owner
 
Join Date: Jun 2007
Location: Coaldale, AB
Posts: 64
Thank you I will look at that today.
__________________
05 Itasca Sunova 29R
TAN is offline   Reply With Quote
Old 05-09-2013, 10:38 AM   #12
TAN
Winnebago Owner
 
Join Date: Jun 2007
Location: Coaldale, AB
Posts: 64
I have done every thing that was sugested and still can't get them working. Any more help would sure be appreciated, my back is getting raw from crawling around underneath it.
__________________
05 Itasca Sunova 29R
TAN is offline   Reply With Quote
Old 05-09-2013, 11:48 AM   #13
Winnie-Wise
 
Kazoo Tom's Avatar
 
Join Date: Feb 2006
Location: Kalamazoo, Michigan
Posts: 367
After trying all the simple things I can think of and still no luck, I usually revert to the best tool I have for the job - a checkbook or credit card!
__________________
Tom and Barb
'07 Winnebago Voyage 35L
Workhorse W22 chassis FMCA 219315
Kazoo Tom is offline   Reply With Quote
Old 05-09-2013, 02:23 PM   #14
TAN
Winnebago Owner
 
Join Date: Jun 2007
Location: Coaldale, AB
Posts: 64
Thanks Tom that is most likely the best advice yet.
__________________
05 Itasca Sunova 29R
TAN is offline   Reply With Quote
Reply

Tags
jacks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HWH Jacks not working right INSPECTORBOB General Maintenance and Repair 10 08-18-2011 02:28 PM
kwikee jacks not working Gary the Wombat General Maintenance and Repair 15 08-22-2010 03:55 PM
Slide (and now jacks) not working kdetam General Maintenance and Repair 6 10-11-2008 01:54 PM
hydraulic jacks not working ronconp General Maintenance and Repair 6 02-25-2007 06:36 AM
HWH Jacks working, not working and working again? Bob&Pat General Maintenance and Repair 6 06-08-2006 04:22 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:20 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.