Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-19-2018, 07:02 PM   #1
Winnebago Watcher
 
Join Date: Mar 2018
Posts: 2
Engine will not start

We bought a used 2006 Winnebego Itasca. Had no issues at first but after a faulty rear light was repaired, the engine will not start. Have 3 mechanics baffled. When you turn on the key, there is a "click" from the solenoid, the fuel pump does not come on, and no dash lights. Somehow we are not feeding voltage to the 2 center panels in the fuse box in the engine compartment. When we jump electricity into the 2 panels, everything will start but cannot keep running because the wires heat up and have concern about overheating wires in other areas. Any one ever have a mystery electrical issue in an Itasca?
We absolutely love the Itasca, it is our 2nd RV and our first Winnebego.
Jennifer is offline   Reply With Quote
Old 03-20-2018, 02:40 PM   #2
Winnebago Camper
 
Join Date: Dec 2017
Posts: 8
There should be a maxi fuse 60amp. Normally located at the end of the aux fuse box in engine compartment. I would start there.
passinthru is offline   Reply With Quote
Old 03-22-2018, 06:28 PM   #3
Winnebago Watcher
 
Join Date: Mar 2018
Posts: 2
Thank you very much for the info and we will try that!
Jennifer is offline   Reply With Quote
Reply

Tags
engine


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No power to engine start budbon General Maintenance and Repair 10 03-08-2018 04:36 AM
Engine won't start after battery charge ewaldo Electrical | Charging, Solar and Electronics 7 11-26-2013 09:12 PM
Generator will not start osgoor Electrical | Charging, Solar and Electronics 17 07-17-2013 08:19 AM
engine bat bad no boost start ron55 General Maintenance and Repair 7 04-05-2010 10:29 AM
Propane Furnace does not start RNM General Maintenance and Repair 8 07-14-2008 02:15 PM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:11 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.