Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-19-2012, 09:46 PM   #1
Winnebago Owner
 
Magumba's Avatar
 
Join Date: Oct 2009
Location: On the Road
Posts: 74
Basement air high blower light not illuminated

Hi,
Hot weather this summer so of course we are having air conditioning problems. This just started in the past week.

The air conditioner runs and makes cold air but only really works well on cooler days. I've kept up on the filter changes. We had the ducts in the rear cap resealed and they are still tight.

Today I opened up the circuit board cover and found that the green high blower light is not on.

Any thoughts on what I can check? Thanks for your help.

In searching the forum I noticed several posts saying not to use the fancy air filters but rather get the cheap kind. I'll change to that tomorrow.
__________________
2003 Itasca Suncruiser 38G
1998 Jeep Cherokee. Ready Brute Elite tow bar and brake. Tow Mate wireless light bar.
Magumba is offline   Reply With Quote
Old 07-20-2012, 08:04 AM   #2
Winnebago Master
 
Tom N's Avatar
 
Join Date: Dec 2002
Location: Sarver, PA/Crystal River, FL/Shelocta, PA
Posts: 1,196
You should be able to download the service manual from RV Products website.

http://www.rvcomfort.com/rvp/tech_info/

If not I can email it to you.

Below is the page that troubleshoots the "NO green LED light".

-Tom

http://www.irv2.com/photopost/showfull.php?photo=21843


__________________
Sarver, PA/Crystal River, FL/Shelocta, PA FMCA 335149 W3TLN
2005 Suncruiser 38R W24, no chassis mods needed 2013 Honda Accord EX-L 2008 Honda Odyssey EX-L
[SIGPIC][/SIGPIC]
Tom N is offline   Reply With Quote
Old 07-20-2012, 09:42 AM   #3
Winnebago Owner
 
lwasouth's Avatar
 
Join Date: Oct 2008
Posts: 176
Check where your thermostat is set - some times the high/low fan speed should to be set on high. It make a difference on my 05 horizon
lwasouth is offline   Reply With Quote
Old 07-20-2012, 07:17 PM   #4
Winnebago Owner
 
Magumba's Avatar
 
Join Date: Oct 2009
Location: On the Road
Posts: 74
Thanks for the help I was able to find the online manual tonight so I'll start working on this.
__________________
2003 Itasca Suncruiser 38G
1998 Jeep Cherokee. Ready Brute Elite tow bar and brake. Tow Mate wireless light bar.
Magumba is offline   Reply With Quote
Old 07-23-2012, 02:25 PM   #5
Winnebago Owner
 
Magumba's Avatar
 
Join Date: Oct 2009
Location: On the Road
Posts: 74
Found the problem

After downloading the Service Manual and spending a few hours looking it over I decided to see if I had 12v DC power to the Stage 2 relay and if I did check to see if the relay was closing. I thought going in that the Stage 2 relay was stuck open.

I pulled the 12v connections from the Stage 2 relay and found that I had voltage on the positive wire but the ground wire was open. I then put a jumper wire from the air conditioner chassis to the negative terminal on the relay and the relay closed, the High Blower light illuminated and we have a lot more cold air inside then before. Wow that was easy!

I rang out the wire from the board and it's fine. There is no continuity from ground to the negative terminal. I think I need a new board.

Thanks for your help.
__________________
2003 Itasca Suncruiser 38G
1998 Jeep Cherokee. Ready Brute Elite tow bar and brake. Tow Mate wireless light bar.
Magumba is offline   Reply With Quote
Old 07-23-2012, 02:50 PM   #6
Winnebago Master
 
Tom N's Avatar
 
Join Date: Dec 2002
Location: Sarver, PA/Crystal River, FL/Shelocta, PA
Posts: 1,196
Great.

As complicated as this system looks at first glance, spending some time with the service manual, as you did, makes the system much clearer. Using the LED lights on the board and the downloadable service manual makes the system understandable. Even if one can not find their fault they'll be in a much better position to explain their problem to a service writer or AC repairman.

-Tom
__________________
Sarver, PA/Crystal River, FL/Shelocta, PA FMCA 335149 W3TLN
2005 Suncruiser 38R W24, no chassis mods needed 2013 Honda Accord EX-L 2008 Honda Odyssey EX-L
[SIGPIC][/SIGPIC]
Tom N is offline   Reply With Quote
Old 07-23-2012, 03:08 PM   #7
Winnebago Owner
 
Magumba's Avatar
 
Join Date: Oct 2009
Location: On the Road
Posts: 74
Tom,
I agree it takes a few hours to get the full extent of system and how the system works and how the parts fit together.
I've picked up a good knowledge of electrical systems and schematics from my years as a helicopter pilot. I also worked with a mechanic who was an electrical whiz.
We're finally cooler.

My one question is how long should I use the jumper to power the Stage 2 relay if it takes a week or so to get a new board?
__________________
2003 Itasca Suncruiser 38G
1998 Jeep Cherokee. Ready Brute Elite tow bar and brake. Tow Mate wireless light bar.
Magumba is offline   Reply With Quote
Old 01-11-2013, 01:10 PM   #8
Winnebago Watcher
 
LinCarol's Avatar
 
Join Date: Nov 2010
Location: Sun City, AZ
Posts: 1
Tom,

How do you like your wireless tow light?
__________________
Linda and Ron
Looking for new Georgetown XL
2013 Scion XD
LinCarol is offline   Reply With Quote
Old 01-12-2013, 07:59 AM   #9
Winnebago Owner
 
Magumba's Avatar
 
Join Date: Oct 2009
Location: On the Road
Posts: 74
I like or Towmate light a lot, we've had it for two years and it works every time.
__________________
2003 Itasca Suncruiser 38G
1998 Jeep Cherokee. Ready Brute Elite tow bar and brake. Tow Mate wireless light bar.
Magumba is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Forza Blower only works on high speed Forza Percy Winnebago Class A Motorhomes 6 04-13-2016 01:55 PM
Another blower high speed only post! dc8cappie Electrical | Charging, Solar and Electronics 31 09-07-2010 07:27 AM
Only high speed working on my dash blower Ken & Joyce General Maintenance and Repair 9 01-14-2007 03:37 PM

» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Winnebago Industries or any of its affiliates. This is an independent, unofficial site.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:28 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×